aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-12-14 17:24:28 -0700
committerChristoph Junghans <ottxor@gentoo.org>2015-12-14 17:24:28 -0700
commit98e18f884c5eb090079fa831504e2859c7023300 (patch)
tree5d51b5f78a440614ae0aff260c1454da92dc1798 /sci-chemistry
parentsci-libs/atlas: Warn if incompatible kernel config is set (diff)
downloadsci-98e18f884c5eb090079fa831504e2859c7023300.tar.gz
sci-98e18f884c5eb090079fa831504e2859c7023300.tar.bz2
sci-98e18f884c5eb090079fa831504e2859c7023300.zip
sci-chemistry/gromacs: merge change from 5.1.9999
Package-Manager: portage-2.2.25
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/ChangeLog3
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild42
2 files changed, 28 insertions, 17 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 5248d930c..2caa2a85d 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 15 Dec 2015; Christoph Junghans <ottxor@gentoo.org> gromacs-9999.ebuild:
+ sci-chemistry/gromacs: merge change from 5.1.9999
+
*gromacs-5.1.9999 (20 Aug 2015)
20 Aug 2015; Christoph Junghans <ottxor@gentoo.org> +gromacs-5.1.9999.ebuild:
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 933074f74..031dfcae0 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -4,8 +4,6 @@
EAPI=5
-TEST_PV="5.0-rc1"
-
CMAKE_MAKEFILE_GENERATOR="ninja"
inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo toolchain-funcs
@@ -15,11 +13,13 @@ if [[ $PV = *9999* ]]; then
https://gerrit.gromacs.org/gromacs.git
git://github.com/gromacs/gromacs.git
http://repo.or.cz/r/gromacs.git"
- EGIT_BRANCH="master"
+ [[ $PV = 9999 ]] && EGIT_BRANCH="master" || EGIT_BRANCH="release-${PV:0:1}-${PV:2:1}"
inherit git-r3
+ KEYWORDS=""
else
SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${PN}-${PV/_/-}.tar.gz
- test? ( http://gerrit.gromacs.org/download/regressiontests-${TEST_PV}.tar.gz )"
+ test? ( http://gerrit.gromacs.org/download/regressiontests-${PV}.tar.gz )"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
fi
ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx cpu_flags_x86_avx2"
@@ -32,8 +32,7 @@ HOMEPAGE="http://www.gromacs.org/"
# base, vmd plugins, fftpack from numpy, blas/lapck from netlib, memtestG80 library, mpi_thread lib
LICENSE="LGPL-2.1 UoI-NCSA !mkl? ( !fftw? ( BSD ) !blas? ( BSD ) !lapack? ( BSD ) ) cuda? ( LGPL-3 ) threads? ( BSD )"
SLOT="0/${PV}"
-KEYWORDS=""
-IUSE="X blas boost cuda +doc -double-precision +fftw lapack +make-symlinks mkl mpi +offensive openmp +single-precision test +threads +tng ${ACCE_IUSE}"
+IUSE="X blas boost cuda +doc -double-precision +fftw lapack mkl mpi +offensive openmp +single-precision test +threads +tng ${ACCE_IUSE}"
CDEPEND="
X? (
@@ -83,8 +82,8 @@ src_unpack() {
git-r3_src_unpack
if use test; then
EGIT_REPO_URI="git://git.gromacs.org/regressiontests.git" \
- EGIT_BRANCH="master" EGIT_NOUNPACK="yes" EGIT_COMMIT="master" \
- EGIT_SOURCEDIR="${WORKDIR}/regressiontests"\
+ EGIT_BRANCH="${EGIT_BRANCH}" \
+ EGIT_CHECKOUT_DIR="${WORKDIR}/regressiontests"\
git-r3_src_unpack
fi
fi
@@ -154,7 +153,6 @@ src_configure() {
$(cmake-utils_use boost GMX_EXTERNAL_BOOST)
$(cmake-utils_use tng GMX_USE_TNG)
$(cmake-utils_use doc GMX_BUILD_MANUAL)
- $(cmake-utils_use make-symlinks GMX_SYMLINK_OLD_BINARY_NAMES)
-DGMX_DEFAULT_SUFFIX=off
-DGMX_SIMD="$acce"
-DGMX_LIB_INSTALL_DIR="$(get_libdir)"
@@ -188,6 +186,8 @@ src_configure() {
-DGMX_LIBS_SUFFIX="${suffix}"
)
BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
+ [[ ${CHOST} != *-darwin* ]] || \
+ sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
mycmakeargs=(
@@ -202,6 +202,8 @@ src_configure() {
-DGMX_LIBS_SUFFIX="_mpi${suffix}"
)
BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" CC="mpicc" cmake-utils_src_configure
+ [[ ${CHOST} != *-darwin* ]] || \
+ sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}_mpi/gentoo_rules.cmake" || die
done
}
@@ -210,9 +212,7 @@ src_compile() {
einfo "Compiling for ${x} precision"
BUILD_DIR="${WORKDIR}/${P}_${x}"\
cmake-utils_src_compile
- # generate bash completion
- BUILD_DIR="${WORKDIR}/${P}_${x}"\
- cmake-utils_src_compile completion
+ # not 100% necessary for rel ebuilds as available from website
if use doc; then
BUILD_DIR="${WORKDIR}/${P}_${x}"\
cmake-utils_src_compile manual
@@ -238,16 +238,24 @@ src_install() {
if use doc; then
newdoc "${WORKDIR}/${P}_${x}"/docs/manual/gromacs.pdf "${PN}-manual-${PV}.pdf"
fi
- newbashcomp "${WORKDIR}/${P}_${x}"/src/programs/completion/gmx-completion.bash gromacs
use mpi || continue
BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
cmake-utils_src_install
done
- # drop unneeded stuff
- rm -f "${ED}"usr/bin/gmx-completion*
- rm -f "${ED}"usr/bin/g_options*
- rm -f "${ED}"usr/bin/GMXRC*
+ if use tng; then
+ insinto /usr/include/tng
+ doins src/external/tng_io/include/tng/*h
+ fi
+ # drop unneeded stuff
+ rm "${ED}"usr/bin/GMXRC* || die
+ for x in "${ED}"usr/bin/gmx-completion-*.bash ; do
+ local n=${x##*/gmx-completion-}
+ n="${n%.bash}"
+ cat "${ED}"usr/bin/gmx-completion.bash "$x" > "${T}/${n}" || die
+ newbashcomp "${T}"/"${n}" "${n}"
+ done
+ rm "${ED}"usr/bin/gmx-completion*.bash || die
readme.gentoo_create_doc
}