aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-11-04 21:15:23 -0600
committerChristoph Junghans <ottxor@gentoo.org>2011-11-04 21:15:23 -0600
commitb286a80be04238e773f8ec9fb38cb77607a380a9 (patch)
tree81064a50c9895f8946e6579a9e672bebd1d50262 /sci-chemistry
parentinitial commit (diff)
downloadsci-b286a80be04238e773f8ec9fb38cb77607a380a9.tar.gz
sci-b286a80be04238e773f8ec9fb38cb77607a380a9.tar.bz2
sci-b286a80be04238e773f8ec9fb38cb77607a380a9.zip
initial commit
(Portage version: 2.2.0_alpha72/git/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/votca-moo/ChangeLog10
-rw-r--r--sci-chemistry/votca-moo/Manifest17
-rw-r--r--sci-chemistry/votca-moo/metadata.xml12
-rw-r--r--sci-chemistry/votca-moo/votca-moo-9999.ebuild41
4 files changed, 80 insertions, 0 deletions
diff --git a/sci-chemistry/votca-moo/ChangeLog b/sci-chemistry/votca-moo/ChangeLog
new file mode 100644
index 000000000..5b851a28b
--- /dev/null
+++ b/sci-chemistry/votca-moo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/votca-moo
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*votca-moo-9999 (05 Nov 2011)
+
+ 05 Nov 2011; Christoph Junghans <ottxor@gentoo.org> +votca-moo-9999.ebuild,
+ +metadata.xml:
+ initial commit
+
diff --git a/sci-chemistry/votca-moo/Manifest b/sci-chemistry/votca-moo/Manifest
new file mode 100644
index 000000000..fb09ed245
--- /dev/null
+++ b/sci-chemistry/votca-moo/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+EBUILD votca-moo-9999.ebuild 845 RMD160 7c20b86d2dd3e943a8c164c701451b3eb3aa083a SHA1 474e3fd110a4a68fa8ddf79d551a24b4210e9fc0 SHA256 524087eeed69cbeacd5a4b73a4cbac0d395344ea4f2abc9f176054af97916b05
+MISC ChangeLog 268 RMD160 5ff3a2a861a27a025c861b08300f7fc6edbf5eda SHA1 f8c4b7a4e39ca34349f1a2e6f50f28240e40746c SHA256 c2460eddafeb1278fc5f5f6107cf713dd210ce5f8ae31d8d9b818d68749c343e
+MISC metadata.xml 383 RMD160 8767f93217531b7cb1b96560985dd76572b9a1a2 SHA1 948cb7b06acf9e89cd7810dec08e20fddd14c9bb SHA256 d1448ce3393b6092cc8753edd4cdca52ff1c8451e58859ee2f520381b325bf82
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iQEcBAEBAgAGBQJOtKpLAAoJEOeBhlrCAAWGqdEIAIh4vT8tWEnCoDi4GMF8jOBY
+9fw8+ouqjxvWKkAadh3dk8803dKA0LEFXF7hCG/C04X6Zr9FphOV5Ed1eFkFTUCp
+wRBv8OqGRSybSRUqsWnd8JXRr7ifQ11FotF8u8vfsbuN6butxrlryiMEyMe0juy9
+99IISwp6Ju83jUUMBX2K64fUnGhGYoSbFmxelvtrjP+CFXSwAr4taalbSf6MFUtI
+83ZOW6ZeVhD+MgmewmUMf/bMTvYB38xVtwz9nDkK+wIvwdO/oN2XLbA6PSW1toii
+BDaCieANCTR7qxKwn4cYxCo0av07YPruftQPkjgHpFGPbIlz1J16I0M+nIqAQD8=
+=prMA
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/votca-moo/metadata.xml b/sci-chemistry/votca-moo/metadata.xml
new file mode 100644
index 000000000..378b4127e
--- /dev/null
+++ b/sci-chemistry/votca-moo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name='system-boost'>Use system boost (<pkg>dev-libs/boost</pkg>) instead of bundled one</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-chemistry/votca-moo/votca-moo-9999.ebuild b/sci-chemistry/votca-moo/votca-moo-9999.ebuild
new file mode 100644
index 000000000..5b7340782
--- /dev/null
+++ b/sci-chemistry/votca-moo/votca-moo-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils multilib
+
+IUSE="+system-boost"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca-ctp.googlecode.com/files/${PF}.tar.gz"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://moo.votca-ctp.googlecode.com/hg"
+ EHG_REVISION="default"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca molecular orbital overlap code"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="=sci-libs/votca-tools-${PV}[system-boost=]"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( README NOTICE )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}