aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-06-02 11:40:15 -0600
committerChristoph Junghans <ottxor@gentoo.org>2013-06-02 11:40:26 -0600
commitbc4bf551f3e119a3960e469530cc3695bd80cc92 (patch)
tree808d2295be148989e494cb51e313797b1561c5d0 /sci-chemistry
parentsync with gx86 (diff)
downloadsci-bc4bf551f3e119a3960e469530cc3695bd80cc92.tar.gz
sci-bc4bf551f3e119a3960e469530cc3695bd80cc92.tar.bz2
sci-bc4bf551f3e119a3960e469530cc3695bd80cc92.zip
initial commit
Package-Manager: portage-2.2.0_alpha177
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mdsctk/ChangeLog9
-rw-r--r--sci-chemistry/mdsctk/Manifest1
-rw-r--r--sci-chemistry/mdsctk/mdsctk-1.0.0.ebuild51
-rw-r--r--sci-chemistry/mdsctk/metadata.xml12
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-chemistry/mdsctk/ChangeLog b/sci-chemistry/mdsctk/ChangeLog
new file mode 100644
index 000000000..83aa8bc59
--- /dev/null
+++ b/sci-chemistry/mdsctk/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-chemistry/mdsctk
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mdsctk-1.0.0 (02 Jun 2013)
+
+ 02 Jun 2013; Christoph Junghans <ottxor@gentoo.org> +mdsctk-1.0.0.ebuild,
+ +metadata.xml:
+ initial commit
diff --git a/sci-chemistry/mdsctk/Manifest b/sci-chemistry/mdsctk/Manifest
new file mode 100644
index 000000000..6517eec90
--- /dev/null
+++ b/sci-chemistry/mdsctk/Manifest
@@ -0,0 +1 @@
+DIST mdsctk-1.0.0.tar.gz 2476647 SHA256 e1b15dd9c8f950824d8aebd633987761793eea76d8234610a1fb2b94f3895eb1 SHA512 60fb0bc93776309c1a20fb2ffaee3e8d6c7a31724b3139e923a41c6ef23110c78d2b273e30c827b772c0e17e2835ebb3873b127e18447566ec78a2b428a2294d WHIRLPOOL 3598b1a01a12e0557cb160f0c0b0e6d76faddf6026f39eedd3d8c3336cefcc706c37b543d777cca598457820113283261b44fb20eadff63abde096e544376c29
diff --git a/sci-chemistry/mdsctk/mdsctk-1.0.0.ebuild b/sci-chemistry/mdsctk/mdsctk-1.0.0.ebuild
new file mode 100644
index 000000000..5601f7e5c
--- /dev/null
+++ b/sci-chemistry/mdsctk/mdsctk-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit db-use toolchain-funcs
+
+DESCRIPTION="Molecular Dynamics Spectral Clustering Toolkit"
+HOMEPAGE="http://cnls.lanl.gov/~jphillips/?page_id=45"
+SRC_URI="http://cnls.lanl.gov/~jphillips/wp-content/uploads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples R"
+
+DEPEND="
+ sci-chemistry/gromacs
+ sci-libs/gsl
+ sys-libs/db[cxx]
+ virtual/blas
+ virtual/lapack
+ R? ( dev-lang/R )
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local libdb=$(db_libname)
+ emake CPP=$(tc-getCXX) \
+ CFLAGS="${CXXFLAGS} $($(tc-getPKG_CONFIG) --cflags libgmx) \
+ $($(tc-getPKG_CONFIG) --cflags gsl) \
+ $($(tc-getPKG_CONFIG) --cflags lapack) \
+ $($(tc-getPKG_CONFIG) --cflags blas) \
+ -I$(db_includedir)" \
+ LIBS="$($(tc-getPKG_CONFIG) --libs libgmx) -lgmxana \
+ $($(tc-getPKG_CONFIG) --libs gsl) \
+ $($(tc-getPKG_CONFIG) --libs lapack) \
+ $($(tc-getPKG_CONFIG) --libs blas) \
+ -l${libdb/db/db_cxx} ${LDFLAGS}" \
+ OPTIONS=""
+}
+
+src_install() {
+ dodoc AUTHORS README
+ dobin auto_decomp_sparse bb_xtc_to_phipsi check_xtc decomp_sparse knn_data \
+ knn_rms knn_rms_sparse make_sparse phipsi_to_sincos rms_test
+ use R && dobin clustering_histogram.r clustering_nmi.r kmeans.r plot_histogram.r
+ insinto /usr/share/"${PN}"/examples
+ use examples && doins -r examples
+}
diff --git a/sci-chemistry/mdsctk/metadata.xml b/sci-chemistry/mdsctk/metadata.xml
new file mode 100644
index 000000000..d24286a75
--- /dev/null
+++ b/sci-chemistry/mdsctk/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name="R">Install <pkg>dev-lang/R</pkg> as well</flag>
+ </use>
+</pkgmetadata>