aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott Alfter <salfter@catholiccharities.com>2022-07-25 10:22:17 -0700
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-08 20:46:59 +0200
commit4dc9caa6ff4caaccfa27a67324725df1d372ecc9 (patch)
tree75d8459a49d29fc67829abe237d5fabc40ac5a7f /sci-electronics/minipro/minipro-0.5.ebuild
parentdev-python/numba: drop 0.54.0, 0.55.0 (diff)
downloadsci-4dc9caa6ff4caaccfa27a67324725df1d372ecc9.tar.gz
sci-4dc9caa6ff4caaccfa27a67324725df1d372ecc9.tar.bz2
sci-4dc9caa6ff4caaccfa27a67324725df1d372ecc9.zip
sci-electronics/minipro: version bump 0.5
Signed-off-by: Scott Alfter <scott@alfter.us> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/sci/pull/1163
Diffstat (limited to 'sci-electronics/minipro/minipro-0.5.ebuild')
-rw-r--r--sci-electronics/minipro/minipro-0.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-electronics/minipro/minipro-0.5.ebuild b/sci-electronics/minipro/minipro-0.5.ebuild
new file mode 100644
index 000000000..60854d55c
--- /dev/null
+++ b/sci-electronics/minipro/minipro-0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev
+
+DESCRIPTION="A free and open TL866XX programmer"
+HOMEPAGE="https://gitlab.com/DavidGriffith/minipro"
+SRC_URI="https://gitlab.com/DavidGriffith/minipro/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}