aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan M. Simons <marten_@_xtal.rwth-aachen_._de>2012-11-23 09:20:16 +0100
committerJan M. Simons <marten_@_xtal.rwth-aachen_._de>2012-11-23 09:20:16 +0100
commitebe94c851eb7cdf8ce83d774d9ca08b49c0ed8be (patch)
tree39f3d94ab280dbff687305c0271ea057c1e8193c /sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild
parentimproved ebuild for fullprof (diff)
downloadsci-ebe94c851eb7cdf8ce83d774d9ca08b49c0ed8be.tar.gz
sci-ebe94c851eb7cdf8ce83d774d9ca08b49c0ed8be.tar.bz2
sci-ebe94c851eb7cdf8ce83d774d9ca08b49c0ed8be.zip
improved ebuild for fullprof, added docs + examples useflags
Diffstat (limited to 'sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild')
-rw-r--r--sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild b/sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild
index 998bb9825..597f555bc 100644
--- a/sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild
+++ b/sci-geosciences/fullprof-bin/fullprof-bin-2012.5.ebuild
@@ -4,8 +4,7 @@
EAPI="4"
-DESCRIPTION="a set of crystallographic programs mainly developed for Rietveld \
-analysis"
+DESCRIPTION="a set of crystallographic tools mainly for Rietveld analysis"
HOMEPAGE="http://www.ill.eu/sites/fullprof/index.html"
SRC_URI="http://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_May2012_Lin.tgz"
LICENSE="freedist HPND"
@@ -13,7 +12,7 @@ LICENSE="freedist HPND"
# those two seem to be appropriate.
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="+X"
+IUSE="+X +doc +examples"
RDEPEND="X? ( >=x11-libs/motif-2.3 )"
@@ -25,6 +24,19 @@ src_install() {
echo "PATH=\"${BASEDIR}\"" >> 99fullprof
doenvd 99fullprof
rm 99fullprof || die
+ if use !examples; then
+ rm -r Examples || die
+ fi
+ if use !doc; then
+ rm -r Docs || die
+ rm -r Html || die
+ else
+ # fix html documentation to actually work
+ ls Docs/*.HTM | while read file
+ do
+ mv $file `echo $file | sed 's/\/.*/\L&/'`
+ done
+ fi
mkdir -p "${D}/${BASEDIR}" || die
mv "${S}"/* "${D}/${BASEDIR}" || die
}