aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <tim@cerazone.net>2012-06-16 19:33:26 -0400
committertimcera <tim@cerazone.net>2012-06-16 19:33:26 -0400
commit6c0d1fbd6a2c8bc94a72582191069fcf93bbe219 (patch)
tree73c22847a4349705f722d70515f5b9ced535b425 /sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
parentsci-geosciences/harmonics-dwf-free: Version bump. (diff)
downloadsci-6c0d1fbd6a2c8bc94a72582191069fcf93bbe219.tar.gz
sci-6c0d1fbd6a2c8bc94a72582191069fcf93bbe219.tar.bz2
sci-6c0d1fbd6a2c8bc94a72582191069fcf93bbe219.zip
sci-geosciences/libtcd: Version bump. Removed "non-commercial" use since
upstream received a take-down notice and the "non-commercial" dataset is no longer available. (Portage version: 2.1.10.49/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild')
-rw-r--r--sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild b/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
new file mode 100644
index 000000000..bd78e0a1c
--- /dev/null
+++ b/sci-geosciences/libtcd/libtcd-2.2.5_p2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Upstream used -r# at the end of their files which would mess up gentoo's use
+# of -r#. Name ebuild _p# instead and replace as needed...
+MY_P=${PN}-${PV/_p/-r}
+
+DESCRIPTION="Library for reading and writing Tide Constituent Database (TCD) files."
+HOMEPAGE="http://www.flaterco.com/xtide/libtcd.html"
+SRC_URI="ftp://ftp.flaterco.com/xtide/${MY_P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=sci-geosciences/harmonics-dwf-free-20120302"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P%_*}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc ; then
+ dohtml libtcd.html
+ fi
+}