aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <tim@cerazone.net>2012-04-10 23:40:19 -0400
committertimcera <tim@cerazone.net>2012-04-10 23:40:19 -0400
commit537d134bdbc39b81f0f706dc0c0aba291afaf6c9 (patch)
treebfca7685c37cf08c1bca5e7fb70394386021c696 /sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.1.ebuild
parent[sci-libs/trilinos] Solved many issues. (diff)
downloadsci-537d134bdbc39b81f0f706dc0c0aba291afaf6c9.tar.gz
sci-537d134bdbc39b81f0f706dc0c0aba291afaf6c9.tar.bz2
sci-537d134bdbc39b81f0f706dc0c0aba291afaf6c9.zip
sci-geosciences/pydap and pydap plugins:
* Version bumps for: + pydap + pydap_handlers_hdf5 + pydap_handlers_nca + pydap_handlers_netcdf + pydap_handlers_sql + pydap_responses_matlab + pydap_responses_netcdf * Upstream didn't include setup.py files in a some of the plugins. Now create a new setup.py file using 'paver'. This impacts the following plugins: + pydap_handlers_hdf5 + pydap_handlers_netcdf + pydap_handlers_sql + pydap_responses_matlab + pydap_handlers_netcdf
Diffstat (limited to 'sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.1.ebuild')
-rw-r--r--sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.1.ebuild b/sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.1.ebuild
new file mode 100644
index 000000000..e8195bb3c
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN=${PN//_/.}
+MY_P=${P//_/.}
+
+DESCRIPTION="NetCDF handler for Pydap Data Access Protocol server."
+HOMEPAGE="http://pydap.org/"
+
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="pydap"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6_rc3
+ >=dev-python/paver-1.0.4"
+RDEPEND="
+ >=sci-geosciences/pydap-3.0_rc8
+ >=dev-python/pupynere-1.0.8
+ >=dev-python/arrayterator-1.0.1"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ paver generate_setup || die
+ distutils_src_prepare
+}