aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <timcera@earthlink.net>2010-08-08 13:06:56 -0400
committertimcera <timcera@earthlink.net>2010-08-08 13:06:56 -0400
commit2a54435c44c5e8845ad159f7a2bad0f885bd6e90 (patch)
treecfbca4752d784d56db8be780aa1fb55297f6670e /sci-geosciences/pydap_handlers_proxy
parentsci-geosciences/pydap_handlers_nca: Version bump and change to SRC_URI to use... (diff)
downloadsci-2a54435c44c5e8845ad159f7a2bad0f885bd6e90.tar.gz
sci-2a54435c44c5e8845ad159f7a2bad0f885bd6e90.tar.bz2
sci-2a54435c44c5e8845ad159f7a2bad0f885bd6e90.zip
Initial ebuild.
Diffstat (limited to 'sci-geosciences/pydap_handlers_proxy')
-rw-r--r--sci-geosciences/pydap_handlers_proxy/ChangeLog10
-rw-r--r--sci-geosciences/pydap_handlers_proxy/Manifest4
-rw-r--r--sci-geosciences/pydap_handlers_proxy/metadata.xml13
-rw-r--r--sci-geosciences/pydap_handlers_proxy/pydap_handlers_proxy-0.1.1.ebuild30
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/pydap_handlers_proxy/ChangeLog b/sci-geosciences/pydap_handlers_proxy/ChangeLog
new file mode 100644
index 000000000..f8934f172
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_proxy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-geosciences/pydap_handlers_proxy
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pydap_handlers_proxy-0.1.1 (08 Aug 2010)
+
+ 08 Aug 2010; Tim Cera <timcera@earthlink.net>
+ +pydap_handlers_proxy-0.1.1.ebuild, +metadata.xml:
+ Initial ebuild.
+
diff --git a/sci-geosciences/pydap_handlers_proxy/Manifest b/sci-geosciences/pydap_handlers_proxy/Manifest
new file mode 100644
index 000000000..c6f60eb3b
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_proxy/Manifest
@@ -0,0 +1,4 @@
+DIST pydap.handlers.proxy-0.1.1.tar.gz 31416 RMD160 6d44abbd0996d4b844cca64f9bcedac59c166195 SHA1 2a74098347e241bcd4a6f26ff842c49a188e2d46 SHA256 231752138bb7553c4d45bfc1dbeff3a33ccdff84088bf64a10bea4bbed5273a9
+EBUILD pydap_handlers_proxy-0.1.1.ebuild 660 RMD160 5370d0e7a855c639b7263a88069309419b8efe96 SHA1 592c4ceb6e2469e4a3702da1f88836ceba55b444 SHA256 028bd32ae7779e460cab472c04c4ca0091214408e2180e69dffe6b649781491b
+MISC ChangeLog 300 RMD160 859168a2f874b6951e039ea6a052fa74c1b833fd SHA1 925edbef393b6cc42fb6da9fff7370b8e10ec75e SHA256 8d602b97a882e33cf590b81927f10f2d25efb2eb69f4ce41989b1685fcecb3cc
+MISC metadata.xml 438 RMD160 b0d4350a1d04b00a8dec45fdafe881f0197dcdc3 SHA1 f904d0c4a9d803ee3ed4b275e9af90306c29b5bd SHA256 c3a00623a78fd71cba258aa1e3be9b3bc5f487bd8a527ab7c53130deb916c5f9
diff --git a/sci-geosciences/pydap_handlers_proxy/metadata.xml b/sci-geosciences/pydap_handlers_proxy/metadata.xml
new file mode 100644
index 000000000..ee40eee6b
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_proxy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>timcera@earthlink.net</email>
+<name>Tim Cera</name>
+</maintainer>
+<longdescription lang="en">
+ Pydap is a pure Python library implementing the Data Access Protocol.
+ pydap_handlers_proxy allows Pydap server to serve data from other web sites.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-geosciences/pydap_handlers_proxy/pydap_handlers_proxy-0.1.1.ebuild b/sci-geosciences/pydap_handlers_proxy/pydap_handlers_proxy-0.1.1.ebuild
new file mode 100644
index 000000000..af5d89232
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_proxy/pydap_handlers_proxy-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN=${PN//_/.}
+MY_P=${P//_/.}
+
+DESCRIPTION="Proxy handler for Pydap server that can serve data from other web sites."
+HOMEPAGE="http://pydap.org/handlers.html#cdms"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="pydap"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6_rc3"
+RDEPEND=">=sci-geosciences/pydap-3.0_rc8
+ >=dev-python/paste-1.7.2
+ >=dev-python/configobj-4.6.0"
+
+S="$WORKDIR/$MY_P"