aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <tim@cerazone.net>2011-11-22 21:58:17 -0500
committertimcera <tim@cerazone.net>2011-11-22 21:58:17 -0500
commita93d1f651861b6ed1f1a76d47f0b9dd03ca1fa0a (patch)
treedc131e8577052799458c765d5a00c7a5bcbb697d /sci-geosciences/pydap_handlers_sqlite/pydap_handlers_sqlite-0.1.0.ebuild
parentsci-geosciences/pydap_handlers_sql: Version bump. (diff)
downloadsci-a93d1f651861b6ed1f1a76d47f0b9dd03ca1fa0a.tar.gz
sci-a93d1f651861b6ed1f1a76d47f0b9dd03ca1fa0a.tar.bz2
sci-a93d1f651861b6ed1f1a76d47f0b9dd03ca1fa0a.zip
sci-geosciences/pydap_handlers_sqlite: Initial build.
Diffstat (limited to 'sci-geosciences/pydap_handlers_sqlite/pydap_handlers_sqlite-0.1.0.ebuild')
-rw-r--r--sci-geosciences/pydap_handlers_sqlite/pydap_handlers_sqlite-0.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-geosciences/pydap_handlers_sqlite/pydap_handlers_sqlite-0.1.0.ebuild b/sci-geosciences/pydap_handlers_sqlite/pydap_handlers_sqlite-0.1.0.ebuild
new file mode 100644
index 000000000..dc74dbcac
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_sqlite/pydap_handlers_sqlite-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN=${PN//_/.}
+MY_P=${P//_/.}
+
+DESCRIPTION="Handler for Pydap server that allows serving data from SQLite files"
+HOMEPAGE="http://pydap.org/handlers.html#sqlite"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="pydap"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6_rc3"
+RDEPEND="
+ >=sci-geosciences/pydap-3.0
+ >=dev-python/simplejson-2.1.6
+ >=dev-python/numpy-1.5.1"
+
+S="$WORKDIR/$MY_P"