aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinis Danne <rei4dan@gmail.com>2014-02-16 14:51:00 +0200
committerReinis Danne <rei4dan@gmail.com>2014-02-16 14:51:00 +0200
commit15b26e1e99139b59bfb7471e382044235e8dec91 (patch)
tree978ce1b513973f79f64600609104d3b4d94affb3 /sci-libs/armadillo
parentMerge pull request #192 from Reinis/fix_mlpack_test_build (diff)
downloadsci-15b26e1e99139b59bfb7471e382044235e8dec91.tar.gz
sci-15b26e1e99139b59bfb7471e382044235e8dec91.tar.bz2
sci-15b26e1e99139b59bfb7471e382044235e8dec91.zip
Revert "Merge pull request #191 from Reinis/arma_no_wrapper"
This reverts commit 5ed90a02f0196b790d969b2f26dfc7a3462f453b, reversing changes made to aeccee21a18a8326fb3868dc1745b5e6d266e67c. I was pointed out that armadillo-4 already has this implemented with ARMA_DONT_USE_WRAPPER.
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog4
-rw-r--r--sci-libs/armadillo/armadillo-4.000.3.ebuild1
-rw-r--r--sci-libs/armadillo/files/armadillo-opt_wrapper.patch15
3 files changed, 0 insertions, 20 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 5d0748c8f..e28dc789d 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -2,10 +2,6 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
- 14 Feb 2014; Reinis Danne <rei4dan@gmail.com> armadillo-4.000.3.ebuild,
- +files/armadillo-opt_wrapper.patch:
- Add patch to make the wrapper optional at consumer compile time.
-
10 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> armadillo-4.000.3.ebuild:
sci-libs/armadillo: removed int64 flag, it is only for revdep at compile time
diff --git a/sci-libs/armadillo/armadillo-4.000.3.ebuild b/sci-libs/armadillo/armadillo-4.000.3.ebuild
index c17fbf20b..6dab24828 100644
--- a/sci-libs/armadillo/armadillo-4.000.3.ebuild
+++ b/sci-libs/armadillo/armadillo-4.000.3.ebuild
@@ -40,7 +40,6 @@ PDEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-4.000.3-hdf5.patch \
- "${FILESDIR}"/${PN}-opt_wrapper.patch \
"${FILESDIR}"/${PN}-3.820.1-example-makefile.patch
# avoid the automagic cmake macros
sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
diff --git a/sci-libs/armadillo/files/armadillo-opt_wrapper.patch b/sci-libs/armadillo/files/armadillo-opt_wrapper.patch
deleted file mode 100644
index be5b38684..000000000
--- a/sci-libs/armadillo/files/armadillo-opt_wrapper.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- include/armadillo_bits/config.hpp.cmake 2014-02-14 02:22:31.792051878 +0200
-+++ include/armadillo_bits/config.hpp.cmake 2014-02-14 02:24:56.423587416 +0200
-@@ -29,10 +29,12 @@
- //// ARPACK is required for eigendecompositions of sparse matrices, eg. eigs_sym()
- #endif
-
-+#if !defined(ARMA_NO_WRAPPER)
- #cmakedefine ARMA_USE_WRAPPER
- //// Comment out the above line if you're getting linking errors when compiling your programs,
- //// or if you prefer to directly link with LAPACK, BLAS or ARPACK.
- //// You will then need to link your programs directly with -llapack -lblas instead of -larmadillo
-+#endif
-
- // #define ARMA_BLAS_CAPITALS
- //// Uncomment the above line if your BLAS and LAPACK libraries have capitalised function names (eg. ACML on 64-bit Windows)