aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinis Danne <rei4dan@gmail.com>2014-02-14 15:51:30 +0200
committerReinis Danne <rei4dan@gmail.com>2014-02-14 15:51:30 +0200
commitdd742fe61965e5ab01b7af471620a5c37b22ea18 (patch)
treeadf67952beee48be58778585227f8bbb52b7c75d /sci-libs/armadillo
parentFix build v2 (diff)
downloadsci-dd742fe61965e5ab01b7af471620a5c37b22ea18.tar.gz
sci-dd742fe61965e5ab01b7af471620a5c37b22ea18.tar.bz2
sci-dd742fe61965e5ab01b7af471620a5c37b22ea18.zip
sci-libs/armadillo: Add patch with option to disable wrapper
With this programs can be built only against armadillo headers and linked directly to math libraries by using -DARMA_NO_WRAPPER at compile time.
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog4
-rw-r--r--sci-libs/armadillo/armadillo-4.000.3.ebuild1
-rw-r--r--sci-libs/armadillo/files/armadillo-opt_wrapper.patch15
3 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index e28dc789d..5d0748c8f 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Feb 2014; Reinis Danne <rei4dan@gmail.com> armadillo-4.000.3.ebuild,
+ +files/armadillo-opt_wrapper.patch:
+ Add patch to make the wrapper optional at consumer compile time.
+
10 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> armadillo-4.000.3.ebuild:
sci-libs/armadillo: removed int64 flag, it is only for revdep at compile time
diff --git a/sci-libs/armadillo/armadillo-4.000.3.ebuild b/sci-libs/armadillo/armadillo-4.000.3.ebuild
index 6dab24828..c17fbf20b 100644
--- a/sci-libs/armadillo/armadillo-4.000.3.ebuild
+++ b/sci-libs/armadillo/armadillo-4.000.3.ebuild
@@ -40,6 +40,7 @@ PDEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-4.000.3-hdf5.patch \
+ "${FILESDIR}"/${PN}-opt_wrapper.patch \
"${FILESDIR}"/${PN}-3.820.1-example-makefile.patch
# avoid the automagic cmake macros
sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
diff --git a/sci-libs/armadillo/files/armadillo-opt_wrapper.patch b/sci-libs/armadillo/files/armadillo-opt_wrapper.patch
new file mode 100644
index 000000000..be5b38684
--- /dev/null
+++ b/sci-libs/armadillo/files/armadillo-opt_wrapper.patch
@@ -0,0 +1,15 @@
+--- include/armadillo_bits/config.hpp.cmake 2014-02-14 02:22:31.792051878 +0200
++++ include/armadillo_bits/config.hpp.cmake 2014-02-14 02:24:56.423587416 +0200
+@@ -29,10 +29,12 @@
+ //// ARPACK is required for eigendecompositions of sparse matrices, eg. eigs_sym()
+ #endif
+
++#if !defined(ARMA_NO_WRAPPER)
+ #cmakedefine ARMA_USE_WRAPPER
+ //// Comment out the above line if you're getting linking errors when compiling your programs,
+ //// or if you prefer to directly link with LAPACK, BLAS or ARPACK.
+ //// You will then need to link your programs directly with -llapack -lblas instead of -larmadillo
++#endif
+
+ // #define ARMA_BLAS_CAPITALS
+ //// Uncomment the above line if your BLAS and LAPACK libraries have capitalised function names (eg. ACML on 64-bit Windows)