aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-05-23 17:41:19 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-05-23 17:41:19 +0200
commit515eacebe71737b1aa2ee946b3cf5d97f79787f8 (patch)
tree55d8594d901855f229bc0ad26249eeb43899277e /sci-libs/arrayfire/arrayfire-9999.ebuild
parentsci-libs/ccif: Bump to EAPI=5 (diff)
downloadsci-515eacebe71737b1aa2ee946b3cf5d97f79787f8.tar.gz
sci-515eacebe71737b1aa2ee946b3cf5d97f79787f8.tar.bz2
sci-515eacebe71737b1aa2ee946b3cf5d97f79787f8.zip
sci-libs/arrayfire: Split up ebuilds to fix 9999
Package-Manager: portage-2.2.18
Diffstat (limited to 'sci-libs/arrayfire/arrayfire-9999.ebuild')
-rw-r--r--sci-libs/arrayfire/arrayfire-9999.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/sci-libs/arrayfire/arrayfire-9999.ebuild b/sci-libs/arrayfire/arrayfire-9999.ebuild
index dda442eb6..b976a150b 100644
--- a/sci-libs/arrayfire/arrayfire-9999.ebuild
+++ b/sci-libs/arrayfire/arrayfire-9999.ebuild
@@ -13,13 +13,6 @@ HOMEPAGE="http://www.arrayfire.com/"
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
KEYWORDS=""
-if [[ ${PV} == "0.9999" ]] ; then
- # the remote HEAD points to devel, but we want to pull the master instead
- EGIT_BRANCH="master"
-elif [[ ${PV} == "3.0_beta" ]] ; then
- EGIT_COMMIT="v3.0beta"
- KEYWORDS="~amd64"
-fi
LICENSE="BSD"
SLOT="0"
@@ -34,6 +27,7 @@ RDEPEND="
cpu? (
virtual/blas
virtual/cblas
+ virtual/lapacke
sci-libs/fftw:3.0
)
opencl? (
@@ -48,9 +42,7 @@ BUILD_DIR="${S}/build"
CMAKE_BUILD_TYPE=Release
PATCHES=(
- "${FILESDIR}"/FindCBLAS.patch
- "${FILESDIR}"/FindBoostCompute.patch
- "${FILESDIR}"/opencl_CMakeLists.patch
+ "${FILESDIR}"/${P}-FindCBLAS.patch
)
# We need write acccess /dev/nvidiactl, /dev/nvidia0 and /dev/nvidia-uvm and the portage
@@ -74,6 +66,9 @@ src_unpack() {
unpack ${A}
mv "${BUILD_DIR}"/third_party/src/gtest-"${GTEST_PV}" "${BUILD_DIR}"/third_party/src/googletest || die
fi
+
+ rm "${S}"/CMakeModules/build_boost_compute.cmake || die
+ cp "${FILESDIR}"/FindBoostCompute.cmake "${S}"/CMakeModules/ || die
}
src_configure() {