aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2012-12-12 14:40:21 -0800
committerSébastien Fabbro <bicatali@gentoo.org>2012-12-12 14:40:21 -0800
commite9fc46c9ee86898fe284095cb1b9a2951f46d896 (patch)
treeae36859580fa10d7e03fdbc6a71ce5e5379b6d2f /sci-libs/blas-reference
parentsci-libs/levmar: Use virtual/pkgconfig and prefix keywords (diff)
downloadsci-e9fc46c9ee86898fe284095cb1b9a2951f46d896.tar.gz
sci-e9fc46c9ee86898fe284095cb1b9a2951f46d896.tar.bz2
sci-e9fc46c9ee86898fe284095cb1b9a2951f46d896.zip
Removed unused dependencies
Diffstat (limited to 'sci-libs/blas-reference')
-rw-r--r--sci-libs/blas-reference/blas-reference-20120423.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sci-libs/blas-reference/blas-reference-20120423.ebuild b/sci-libs/blas-reference/blas-reference-20120423.ebuild
deleted file mode 100644
index df3fee011..000000000
--- a/sci-libs/blas-reference/blas-reference-20120423.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit alternatives-2 eutils cmake-utils fortran-2
-
-MYP=lapack-3.4.1
-
-DESCRIPTION="Reference implementation of BLAS"
-HOMEPAGE="http://www.netlib.org/lapack/"
-SRC_URI="http://www.netlib.org/lapack/${MYP}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-RDEPEND="virtual/fortran"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MYP}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${MYP}-cmake.patch
- use static-libs && mkdir "${WORKDIR}/${PN}_static"
-}
-
-src_configure() {
- blas_configure() {
- local mycmakeargs=(
- -DUSE_OPTIMIZED_BLAS=OFF
- $(cmake-utils_use_build test TESTING)
- $@
- )
- cmake-utils_src_configure
- }
-
- blas_configure -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=OFF
- use static-libs && \
- CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" blas_configure \
- -DBUILD_SHARED_LIBS=OFF -DBUILD_STATIC_LIBS=ON
-}
-
-src_compile() {
- cmake-utils_src_compile -C BLAS
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
- cmake-utils_src_compile -C BLAS
-}
-
-src_test() {
- pushd "${CMAKE_BUILD_DIR}/BLAS" > /dev/null
- local ctestargs
- [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
- ctest ${ctestargs} || die
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install -C BLAS
- use static-libs && CMAKE_BUILD_DIR="${WORKDIR}/${PN}_static" \
- cmake-utils_src_install -C BLAS
- alternatives_for blas reference 0 \
- /usr/$(get_libdir)/pkgconfig/blas.pc refblas.pc
-}