aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-08-08 08:54:40 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-08-08 09:20:00 +0800
commite105f0f6a215d6fd15b58cb8a669e3f119c12169 (patch)
treef65746ca51ff785cfe6ba8b9aa9bdd38df0cbd8c /sci-libs/cblas-reference
parentsci-mathematics/petsc: merge into ::gentoo and remove from overlay. (diff)
downloadsci-e105f0f6a215d6fd15b58cb8a669e3f119c12169.tar.gz
sci-e105f0f6a215d6fd15b58cb8a669e3f119c12169.tar.bz2
sci-e105f0f6a215d6fd15b58cb8a669e3f119c12169.zip
virtual/{{c,}blas,lapack{,e}}: replaced by counterparts in ::gentoo.
sci-libs/{{c,}blas,lapack{,e}}-reference: Remove. Remove BLAS/LAPACK migration scripts. Remove outdated documentation on BLAS/LAPACK. Update README.md to point to the new framework in ::gentoo. Reference: https://wiki.gentoo.org/wiki/Blas-lapack-switch Closes: https://github.com/gentoo/sci/issues/805 Closes: https://github.com/gentoo/sci/issues/926 Closes: https://github.com/gentoo/sci/issues/734 Closes: https://github.com/gentoo/sci/issues/897 Closes: https://github.com/gentoo/sci/issues/925 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/cblas-reference')
-rw-r--r--sci-libs/cblas-reference/Manifest3
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20110218-r100.ebuild144
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20151113-r100.ebuild126
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild124
-rw-r--r--sci-libs/cblas-reference/files/lapack-fix-build-system.patch124
-rw-r--r--sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch61
-rw-r--r--sci-libs/cblas-reference/metadata.xml21
7 files changed, 0 insertions, 603 deletions
diff --git a/sci-libs/cblas-reference/Manifest b/sci-libs/cblas-reference/Manifest
deleted file mode 100644
index c1cefc8c3..000000000
--- a/sci-libs/cblas-reference/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST cblas-reference-20110218.tgz 197468 BLAKE2B 8c9aefae422e7beac3ef433f121a152a7669345d0438b76d9bf8278f2a9b22ca29e01f5dbcb816b3f2759979a07d4883834037ba46a3b1d90f734989a5b57f4e SHA512 1c64e6814529cd716890504d213e8cd90150348b9105e8da030718383241a5660d145a14f26e20d27b2aea72c87a9d46b754c6e48935e168d62842c04ba56401
-DIST lapack-3.6.0.tgz 6792324 BLAKE2B 438f3376b63b38ef0fe70f6becac847816f3a11c01f5ab237dc0d941792ceb54dbd2f8dc22d56286f5dab3499289ed94e67521ea951a98973c9640abc294ad6c SHA512 bc50441d415ef8896dd7626d77c6104184b996e758704366288089f03d4c99d068e33153b0d13305310886017e5d2e716130f812a95cfcad36ef37fe20417ab8
-DIST lapack-3.7.0.tgz 7359812 BLAKE2B 20aa42e22d8c920d1360afe41ceec7b36f6cd5fbe43ca9d7848ef7cc45a64a0314cb1321941c1a7c03654f41e28ec805445882ded0ca0ea07674e70b66cba6b5 SHA512 e4f4c7d0ba8a096eeb813160c6dbcdd535647df6b2ad5beac9181908158956b31d1a9554ec9b9836fd44fe7404c1f377b297cbb20d744f20d70e357fd246c91b
diff --git a/sci-libs/cblas-reference/cblas-reference-20110218-r100.ebuild b/sci-libs/cblas-reference/cblas-reference-20110218-r100.ebuild
deleted file mode 100644
index 0d44ec5f2..000000000
--- a/sci-libs/cblas-reference/cblas-reference-20110218-r100.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-NUMERIC_MODULE_NAME="refcblas"
-
-inherit alternatives-2 flag-o-matic fortran-2 multilib numeric numeric-int64-multibuild toolchain-funcs versionator
-
-MYPN="${PN/-reference/}"
-
-DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
-HOMEPAGE="http://www.netlib.org/blas/"
-SRC_URI="http://www.netlib.org/blas/blast-forum/${MYPN}.tgz -> ${P}.tgz"
-
-SLOT="0"
-LICENSE="public-domain"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-RDEPEND="virtual/blas"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/CBLAS"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cblas/cblas.h
-)
-
-static_to_shared() {
- local libstatic=$1
- shift || die
- local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(get_version_component_range 1-2))
- local libdir=$(dirname ${libstatic})
-
- einfo "Making ${soname} from ${libstatic}"
- if [[ ${CHOST} == *-darwin* ]] ; then
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -dynamiclib -install_name "${EPREFIX}"/usr/$(get_libdir)/${soname} \
- -Wl,-all_load -Wl,${libstatic} \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- else
- ${LINK:-$(tc-getCC)} ${LDFLAGS} \
- -shared -Wl,-soname=${soname} \
- -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
- "$@" -o ${libdir}/${soname} || die "${soname} failed"
- if [[ $(get_version_component_count) -gt 1 ]]; then
- ln -s ${soname} ${libdir}/${libname}$(get_libname $(get_major_version)) || die
- fi
- fi
- ln -s ${soname} ${libdir}/${libname}$(get_libname) || die
-}
-
-src_prepare() {
- numeric-int64_ensure_blas_int_support
- find . -name Makefile -exec sed -i \
- -e 's:make:$(MAKE):g' '{}' \; || die
- numeric-int64-multibuild_copy_sources
-}
-
-src_configure() {
- cblas_configure() {
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
- append-cflags -DADD_
- cat > Makefile.in <<-EOF
- BLLIB=$($(tc-getPKG_CONFIG) --libs $(numeric-int64_get_blas_alternative))
- FC=$(tc-getFC) $(get_abi_CFLAGS) $(numeric-int64_get_fortran_int64_abi_fflags)
- CC=$(tc-getCC)
- CBLIB=../lib/lib${libname}.a
- LOADER=\$(FC)
- ARCH=$(tc-getAR)
- ARCHFLAGS=cr
- RANLIB=$(tc-getRANLIB)
- EOF
- }
- numeric-int64-multibuild_foreach_all_abi_variants run_in_build_dir cblas_configure
-}
-
-src_compile() {
- cblas_src_compile() {
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
- emake \
- FFLAGS="${FFLAGS} -fPIC" \
- CFLAGS="${CFLAGS} -fPIC" \
- alllib
- static_to_shared lib/lib${libname}.a $($(tc-getPKG_CONFIG) --libs $(numeric-int64_get_blas_alternative))
- if use static-libs; then
- emake clean
- emake alllib
- fi
- }
- numeric-int64-multibuild_foreach_all_abi_variants run_in_build_dir cblas_src_compile
-}
-
-src_test() {
- cblas_src_test () {
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
- cd testing || die
- emake && emake run
- }
- numeric-int64-multibuild_foreach_all_abi_variants run_in_build_dir cblas_src_test
-}
-
-src_install() {
- cblas_src_install() {
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
- # On linux dynamic libraries are of the form .so.${someversion}
- # On OS X dynamic libraries are of the form ${someversion}.dylib
- if numeric-int64_is_static_build; then
- dolib.a lib/lib${libname}.a
- else
- dolib.so lib/lib${libname}*$(get_libname)*
- insinto /usr/include/cblas
- doins include/cblas.h
- create_pkgconfig \
- --name "${profname}" \
- --libs "-L\${libdir} -l${libname}" \
- --libs-private "-lm" \
- --cflags "-I\${includedir}/cblas $(numeric-int64_get_fortran_int64_abi_fflags)" \
- --requires $(numeric-int64_get_blas_alternative) \
- ${profname}
- fi
-
- if [[ ${#MULTIBUILD_VARIANTS[@]} -gt 1 ]]; then
- multilib_prepare_wrappers
- multilib_check_headers
- fi
- }
- numeric-int64-multibuild_foreach_all_abi_variants run_in_build_dir cblas_src_install
-
- numeric-int64-multibuild_install_alternative cblas reference /usr/include/cblas.h cblas/cblas.h
-
- multilib_install_wrappers
-
- dodoc README
- docinto examples
- dodoc examples/*.c
-}
diff --git a/sci-libs/cblas-reference/cblas-reference-20151113-r100.ebuild b/sci-libs/cblas-reference/cblas-reference-20151113-r100.ebuild
deleted file mode 100644
index 97b7d012f..000000000
--- a/sci-libs/cblas-reference/cblas-reference-20151113-r100.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-NUMERIC_MODULE_NAME="refcblas"
-
-inherit alternatives-2 cmake-utils eutils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs
-
-LPN=lapack
-LPV=3.6.0
-
-DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
-HOMEPAGE="http://www.netlib.org/cblas/"
-SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
-
-LICENSE="BSD"
-SLOT="0/${LPV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="virtual/blas"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${LPN}-${LPV}"
-PATCHES=( "${FILESDIR}/lapack-fix-build-system.patch" )
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cblas/cblas.h
-)
-src_prepare() {
- # the lapack(e)/(c)blas build system is somewhat broken
- # with respect to its pkg-config files.
- epatch "${PATCHES[@]}"
-
- # rename library to avoid collision with other blas implementations
- # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
- # quotes in the following seds. They are later set by defining cmake
- # variables with -DPROFNAME etc in src_configure
- sed -i \
- -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
- -e '/ALL_TARGETS/s:cblas):${LIBNAME}):' \
- -e '/_librar/s:cblas:${LIBNAME}:' \
- CMakeLists.txt \
- CBLAS/src/CMakeLists.txt || die
- sed -i \
- -e 's:/CMAKE/:/cmake/:g' \
- CBLAS/CMakeLists.txt || die
- sed -i \
- -e '/Name: /s:cblas:@PROFNAME@:' \
- -e 's:-lcblas:-l@LIBNAME@:g' \
- CBLAS/cblas.pc.in || die
- sed -i \
- -e 's:cblas):${LIBNAME}):' \
- CBLAS/testing/CMakeLists.txt || die
- sed -i \
- -e 's:BINARY_DIR}/cblas:BINARY_DIR}/${PROFNAME}:' \
- -e '/CBLAS_INCLUDE/s:include ):include/${PROFNAME} ):g' \
- CBLAS/CMakeLists.txt || die
-}
-
-src_configure() {
- cblas_configure() {
- local FCFLAGS="${FCFLAGS}"
- append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
- append-fflags $(get_abi_CFLAGS)
- append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
-
- local blas_profname=$(numeric-int64_get_blas_alternative)
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
-
- local mycmakeargs=(
- -Wno-dev
- -DCBLAS=ON
- -DPROFNAME="${profname}"
- -DLIBNAME="${libname}"
- -DUSE_OPTIMIZED_BLAS=ON
- -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${blas_profname})"
- -DCMAKE_C_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CFLAGS}"
- -DCMAKE_CXX_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CXXFLAGS}"
- -DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(numeric-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
- -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
- $(cmake-utils_use_build test TESTING)
- )
- if $(numeric-int64_is_static_build); then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- -DBUILD_STATIC_LIBS=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STATIC_LIBS=OFF
- )
- fi
- cmake-utils_src_configure
- }
- numeric-int64-multibuild_foreach_all_abi_variants cblas_configure
-}
-
-src_compile() {
- local each target_dirs=( CBLAS )
- use test && target_dirs+=( testing )
- for each in ${target_dirs[@]}; do
- numeric-int64-multibuild_foreach_all_abi_variants \
- cmake-utils_src_compile -C ${each}
- done
-
-}
-
-src_test() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
-}
-
-src_install() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C CBLAS
- numeric-int64-multibuild_install_alternative cblas reference /usr/include/cblas.h refcblas/cblas.h
- multilib_install_wrappers
-}
diff --git a/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild b/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild
deleted file mode 100644
index 152e56324..000000000
--- a/sci-libs/cblas-reference/cblas-reference-20161223-r101.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-NUMERIC_MODULE_NAME="refcblas"
-
-inherit alternatives-2 cmake-utils eutils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs
-
-LPN=lapack
-LPV=3.7.0
-
-DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
-HOMEPAGE="http://www.netlib.org/cblas/"
-SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
-
-LICENSE="BSD"
-SLOT="0/${LPV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="virtual/blas"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${LPN}-${LPV}"
-PATCHES=( "${FILESDIR}/lapack-reference-${LPV}-fix-build-system.patch" )
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/cblas/cblas.h
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # rename library to avoid collision with other blas implementations
- # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
- # quotes in the following seds. They are later set by defining cmake
- # variables with -DPROFNAME etc in src_configure
- sed -i \
- -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
- -e '/ALL_TARGETS/s:cblas):${LIBNAME}):' \
- -e '/_librar/s:cblas:${LIBNAME}:' \
- CMakeLists.txt \
- CBLAS/src/CMakeLists.txt || die
- sed -i \
- -e 's:/CMAKE/:/cmake/:g' \
- CBLAS/CMakeLists.txt || die
- sed -i \
- -e '/Name: /s:cblas:@PROFNAME@:' \
- -e 's:-lcblas:-l@LIBNAME@:g' \
- CBLAS/cblas.pc.in || die
- sed -i \
- -e 's:cblas):${LIBNAME}):' \
- CBLAS/testing/CMakeLists.txt || die
- sed -i \
- -e 's:BINARY_DIR}/cblas:BINARY_DIR}/${PROFNAME}:' \
- -e '/install/s:include):include/${PROFNAME}):g' \
- CBLAS/CMakeLists.txt || die
-}
-
-src_configure() {
- cblas_configure() {
- local FCFLAGS="${FCFLAGS}"
- append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
- append-fflags $(get_abi_CFLAGS)
- append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
-
- local blas_profname=$(numeric-int64_get_blas_alternative)
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
-
- local mycmakeargs=(
- -Wno-dev
- -DCBLAS=ON
- -DPROFNAME="${profname}"
- -DLIBNAME="${libname}"
- -DUSE_OPTIMIZED_BLAS=ON
- -DCMAKE_C_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CFLAGS}"
- -DCMAKE_CXX_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) ${CXXFLAGS}"
- -DCMAKE_Fortran_FLAGS="$($(tc-getPKG_CONFIG) --cflags ${blas_profname}) $(get_abi_CFLAGS) $(numeric-int64_get_fortran_int64_abi_fflags) ${FCFLAGS}"
- -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
- -DBUILD_TESTING=$(usex test)
- )
- if $(numeric-int64_is_static_build); then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- -DBUILD_STATIC_LIBS=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STATIC_LIBS=OFF
- )
- fi
- cmake-utils_src_configure
- }
- numeric-int64-multibuild_foreach_all_abi_variants cblas_configure
-}
-
-src_compile() {
- local each target_dirs=( CBLAS )
- use test && target_dirs+=( testing )
- for each in ${target_dirs[@]}; do
- numeric-int64-multibuild_foreach_all_abi_variants \
- cmake-utils_src_compile -C ${each}
- done
-
-}
-
-src_test() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
-}
-
-src_install() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C CBLAS
- numeric-int64-multibuild_install_alternative cblas reference /usr/include/cblas.h refcblas/cblas.h
- multilib_install_wrappers
-}
diff --git a/sci-libs/cblas-reference/files/lapack-fix-build-system.patch b/sci-libs/cblas-reference/files/lapack-fix-build-system.patch
deleted file mode 100644
index a187dac21..000000000
--- a/sci-libs/cblas-reference/files/lapack-fix-build-system.patch
+++ /dev/null
@@ -1,124 +0,0 @@
- BLAS/CMakeLists.txt | 2 +-
- BLAS/blas.pc.in | 6 ++++--
- CBLAS/CMakeLists.txt | 2 +-
- CBLAS/cblas.pc.in | 9 ++++++---
- CMakeLists.txt | 2 +-
- LAPACKE/CMakeLists.txt | 2 +-
- LAPACKE/lapacke.pc.in | 6 ++++--
- lapack.pc.in | 6 ++++--
- 8 files changed, 22 insertions(+), 13 deletions(-)
-
-diff --git a/BLAS/CMakeLists.txt b/BLAS/CMakeLists.txt
-index 45e68e9..56c8354 100644
---- a/BLAS/CMakeLists.txt
-+++ b/BLAS/CMakeLists.txt
-@@ -2,7 +2,7 @@ add_subdirectory(SRC)
- if(BUILD_TESTING)
- add_subdirectory(TESTING)
- endif(BUILD_TESTING)
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/blas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/blas.pc)
-+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/blas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/blas.pc @ONLY)
- install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/blas.pc
- DESTINATION ${PKG_CONFIG_DIR}
-diff --git a/BLAS/blas.pc.in b/BLAS/blas.pc.in
-index 845a25c..7a53ea5 100644
---- a/BLAS/blas.pc.in
-+++ b/BLAS/blas.pc.in
-@@ -1,5 +1,7 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include
-
- Name: blas
- Description: Basic Linear Algebra Subprograms F77 reference implementations
-diff --git a/CBLAS/CMakeLists.txt b/CBLAS/CMakeLists.txt
-index 98b481f..8f98b04 100644
---- a/CBLAS/CMakeLists.txt
-+++ b/CBLAS/CMakeLists.txt
-@@ -71,7 +71,7 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/CMAKE/cblas-config-build.cmake.in
- ${LAPACK_BINARY_DIR}/cblas-config.cmake @ONLY)
-
-
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cblas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc)
-+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cblas.pc.in ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc @ONLY)
- install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/cblas.pc
- DESTINATION ${PKG_CONFIG_DIR}
-diff --git a/CBLAS/cblas.pc.in b/CBLAS/cblas.pc.in
-index ee20206..14a141e 100644
---- a/CBLAS/cblas.pc.in
-+++ b/CBLAS/cblas.pc.in
-@@ -1,9 +1,12 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include/@PROFNAME@
-
--Name: lapacke
-+Name: cblas-reference
- Description: C Standard Interface to BLAS Linear Algebra PACKage
- Version: @LAPACK_VERSION@
- URL: http://www.netlib.org/lapack/
- Libs: -L${libdir} -lcblas
-+Cflags: -I${includedir}
- Requires: blas
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ab29bd2..31b878a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -333,7 +333,7 @@ configure_file(${LAPACK_SOURCE_DIR}/CMAKE/lapack-config-build.cmake.in
- ${LAPACK_BINARY_DIR}/lapack-config.cmake @ONLY)
-
-
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc)
-+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapack.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc @ONLY)
- install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/lapack.pc
- DESTINATION ${PKG_CONFIG_DIR}
-diff --git a/LAPACKE/CMakeLists.txt b/LAPACKE/CMakeLists.txt
-index 008f24c..d8c4cb0 100644
---- a/LAPACKE/CMakeLists.txt
-+++ b/LAPACKE/CMakeLists.txt
-@@ -65,7 +65,7 @@ if(BUILD_TESTING)
- endif(BUILD_TESTING)
-
-
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapacke.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapacke.pc)
-+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/lapacke.pc.in ${CMAKE_CURRENT_BINARY_DIR}/lapacke.pc @ONLY)
- install(FILES
- ${CMAKE_CURRENT_BINARY_DIR}/lapacke.pc
- DESTINATION ${PKG_CONFIG_DIR}
-diff --git a/LAPACKE/lapacke.pc.in b/LAPACKE/lapacke.pc.in
-index 75e6871..ce5201b 100644
---- a/LAPACKE/lapacke.pc.in
-+++ b/LAPACKE/lapacke.pc.in
-@@ -1,5 +1,7 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include
-
- Name: lapacke
- Description: C Standard Interface to LAPACK Linear Algebra PACKage
-diff --git a/lapack.pc.in b/lapack.pc.in
-index d34c870..0d0750f 100644
---- a/lapack.pc.in
-+++ b/lapack.pc.in
-@@ -1,5 +1,7 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include
-
- Name: lapack
- Description: FORTRAN reference implementation of LAPACK Linear Algebra PACKage
diff --git a/sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch b/sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch
deleted file mode 100644
index 40f3aaa02..000000000
--- a/sci-libs/cblas-reference/files/lapack-reference-3.7.0-fix-build-system.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/BLAS/blas.pc.in b/BLAS/blas.pc.in
-index 7fd6f1e..e52f3ad 100644
---- a/BLAS/blas.pc.in
-+++ b/BLAS/blas.pc.in
-@@ -1,5 +1,7 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include
-
- Name: BLAS
- Description: FORTRAN reference implementation of BLAS Basic Linear Algebra Subprograms
-diff --git a/CBLAS/cblas.pc.in b/CBLAS/cblas.pc.in
-index 4a938fe..269a254 100644
---- a/CBLAS/cblas.pc.in
-+++ b/CBLAS/cblas.pc.in
-@@ -1,9 +1,12 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include/@PROFNAME@
-
- Name: CBLAS
- Description: C Standard Interface to BLAS Basic Linear Algebra Subprograms
- Version: @LAPACK_VERSION@
- URL: http://www.netlib.org/blas/#_cblas
-+Cflags: -I${includedir}
- Libs: -L${libdir} -lcblas
- Requires: blas
-diff --git a/LAPACKE/lapacke.pc.in b/LAPACKE/lapacke.pc.in
-index 028f8da..dc092b1 100644
---- a/LAPACKE/lapacke.pc.in
-+++ b/LAPACKE/lapacke.pc.in
-@@ -1,5 +1,7 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include
-
- Name: LAPACKE
- Description: C Standard Interface to LAPACK Linear Algebra PACKage
-diff --git a/lapack.pc.in b/lapack.pc.in
-index 878efc2..2cca4c2 100644
---- a/lapack.pc.in
-+++ b/lapack.pc.in
-@@ -1,5 +1,7 @@
--prefix=@prefix@
--libdir=@libdir@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-+includedir=${prefix}/include
-
- Name: LAPACK
- Description: FORTRAN reference implementation of LAPACK Linear Algebra PACKage
diff --git a/sci-libs/cblas-reference/metadata.xml b/sci-libs/cblas-reference/metadata.xml
deleted file mode 100644
index eb9d2972b..000000000
--- a/sci-libs/cblas-reference/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
-The BLAS (Basic Linear Algebra Subprograms) are high quality "building
-block" routines for performing basic vector and matrix operations. Level 1
-BLAS do vector-vector operations, Level 2 BLAS do matrix-vector operations,
-and Level 3 BLAS do matrix-matrix operations. Because the BLAS are
-efficient, portable, and widely available, they're commonly used in the
-development of high quality linear algebra software, LAPACK for
-example. This packages implements the reference C library as a wrapper
-to the FORTRAN 77 BLAS library.
-</longdescription>
- <use>
- <flag name="int64">Build the 64 bits integer library</flag>
- </use>
-</pkgmetadata>