aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-01 16:34:10 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-01 16:34:10 +0100
commitb780112169405319383ce7fb775d735c776983c9 (patch)
treeaaca8df0c02d2b23f8609ae764d473a0a5484f5a /sci-libs/chooch
parentsci-chemistry/Cgraph submitt (diff)
downloadsci-b780112169405319383ce7fb775d735c776983c9.tar.gz
sci-b780112169405319383ce7fb775d735c776983c9.tar.bz2
sci-b780112169405319383ce7fb775d735c776983c9.zip
cgraph.h installation fixed
linking fixed
Diffstat (limited to 'sci-libs/chooch')
-rw-r--r--sci-libs/chooch/Manifest2
-rw-r--r--sci-libs/chooch/chooch-5.0.2.ebuild13
2 files changed, 13 insertions, 2 deletions
diff --git a/sci-libs/chooch/Manifest b/sci-libs/chooch/Manifest
index 0633e2aca..286e71bca 100644
--- a/sci-libs/chooch/Manifest
+++ b/sci-libs/chooch/Manifest
@@ -1,3 +1,3 @@
DIST chooch-5.0.2.tar.gz 3057641 RMD160 5eb6d2b33f58e3a0b6379713184cd0c11d3a5956 SHA1 ec6cefd5044487c79e8099329c9f6eb3061e047d SHA256 ad80d5d296bfbd2bb8f9fac930df5a4e9ba583e23b2de298209b7a6925240643
-EBUILD chooch-5.0.2.ebuild 468 RMD160 cf67838d9a356a8c8504db1799c1e14aecad0f02 SHA1 d34ff4b8f4eca7cbbf8e30c0385819cf441fcdb8 SHA256 b6060170d10f297aa4ef398eb6a5c05182329ea1bd03bd09ce2eba808fc79576
+EBUILD chooch-5.0.2.ebuild 692 RMD160 a0313483fd5b8cb6f06e327b2094174a57da818d SHA1 937f617e3ef07986a14ab3c74c2962e9e2ece81f SHA256 c870421b3231aede9fb1c70cbf6a2f9574312748905daac7673d241b3395b478
MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/sci-libs/chooch/chooch-5.0.2.ebuild b/sci-libs/chooch/chooch-5.0.2.ebuild
index c99bc6dc7..69a38496b 100644
--- a/sci-libs/chooch/chooch-5.0.2.ebuild
+++ b/sci-libs/chooch/chooch-5.0.2.ebuild
@@ -16,7 +16,18 @@ KEYWORDS="~amd64 ~x86"
IUSE="X"
RDEPEND="X? ( sci-libs/pgplot )
sci-libs/gsl
- "
+ sci-libs/Cgraph"
DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+src_compile() {
+ rm -rvf cgraph-2.04 gsl-1.4
+ cd chooch-5.0.2
+ econf \
+ $(use_with X x) \
+ --with-gsl-prefix="/usr" \
+ --with-cgraph-prefix="/usr"
+
+ emake -j1|| die
+}