aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-06-05 15:16:27 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-06-05 15:16:27 +0200
commit2c3ad2e6b4c0b35f65720c771052ac5f7d6dba8f (patch)
tree60f1fe5c1dd3f85772654447c6870db00bd050aa /sci-libs/clfft
parentsci-libs/clfft: Fork 2.4 from 9999 (diff)
downloadsci-2c3ad2e6b4c0b35f65720c771052ac5f7d6dba8f.tar.gz
sci-2c3ad2e6b4c0b35f65720c771052ac5f7d6dba8f.tar.bz2
sci-2c3ad2e6b4c0b35f65720c771052ac5f7d6dba8f.zip
sci-libs/clfft: Fork 0.9999 from 9999
Diffstat (limited to 'sci-libs/clfft')
-rw-r--r--[l---------]sci-libs/clfft/clfft-0.9999.ebuild67
1 files changed, 66 insertions, 1 deletions
diff --git a/sci-libs/clfft/clfft-0.9999.ebuild b/sci-libs/clfft/clfft-0.9999.ebuild
index b6c165da9..994dad99c 120000..100644
--- a/sci-libs/clfft/clfft-0.9999.ebuild
+++ b/sci-libs/clfft/clfft-0.9999.ebuild
@@ -1 +1,66 @@
-clfft-9999.ebuild \ No newline at end of file
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_PN="clFFT"
+
+DESCRIPTION="A software library containing FFT functions written in OpenCL"
+HOMEPAGE="https://github.com/clMathLibraries/clFFT"
+
+if [ ${PV} == "9999" ] || [ ${PV} == "0.9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/clMathLibraries/${MY_PN}.git git://github.com/clMathLibraries/${MY_PN}.git"
+ S="${WORKDIR}/${P}/src"
+ if [ ${PV} == "9999" ]; then
+ EGIT_BRANCH="develop"
+ fi
+else
+ SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_PN}-${PV}/src"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=sys-devel/gcc-4.6:*
+ virtual/opencl
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+# test? (
+# dev-cpp/gtest
+# sci-libs/fftw:3.0
+# )"
+
+# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
+# Therefore src_test() won't execute any test.
+RESTRICT="test"
+
+# Patches are only needed for the recent master and releases <= 2.4
+if [ ${PV} != "9999" ]; then
+ PATCHES=(
+ "${FILESDIR}"/clfft-client_CMakeLists.patch
+ "${FILESDIR}"/clfft-scripts_perf_CMakeLists.patch
+ )
+fi
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
+ die "Compilation with gcc older than 4.6 is not supported."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TEST)
+ )
+ cmake-utils_src_configure
+}