aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-06 11:04:07 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-06 11:04:07 +0100
commit4e138bcca1e8cd3028432c630e9774e0230261dd (patch)
tree74531f5416adf2f409a83f896390b086aa7185a0 /sci-libs/clfft
parentdev-python/pamela: Add new package needed for JupyterHub, ebuild written by me (diff)
downloadsci-4e138bcca1e8cd3028432c630e9774e0230261dd.tar.gz
sci-4e138bcca1e8cd3028432c630e9774e0230261dd.tar.bz2
sci-4e138bcca1e8cd3028432c630e9774e0230261dd.zip
sci-libs/clfft: Clean patches
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-libs/clfft')
-rw-r--r--sci-libs/clfft/ChangeLog6
-rw-r--r--sci-libs/clfft/files/clfft-2.4-client_CMakeLists.patch41
-rw-r--r--sci-libs/clfft/files/clfft-2.4-fix-cmake-config-install.patch128
-rw-r--r--sci-libs/clfft/files/clfft-2.4-scripts_perf_CMakeLists.patch33
4 files changed, 6 insertions, 202 deletions
diff --git a/sci-libs/clfft/ChangeLog b/sci-libs/clfft/ChangeLog
index 56c9df818..22dbc1f54 100644
--- a/sci-libs/clfft/ChangeLog
+++ b/sci-libs/clfft/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 06 Nov 2015; Marius Brehler <marbre@linux.sungazer.de>
+ -files/clfft-2.4-client_CMakeLists.patch,
+ -files/clfft-2.4-fix-cmake-config-install.patch,
+ -files/clfft-2.4-scripts_perf_CMakeLists.patch:
+ sci-libs/clfft: Clean patches
+
12 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> clfft-2.6.1.ebuild,
clfft-9999.ebuild, metadata.xml:
sci-libs/clfft: Add client and examples use flag
diff --git a/sci-libs/clfft/files/clfft-2.4-client_CMakeLists.patch b/sci-libs/clfft/files/clfft-2.4-client_CMakeLists.patch
deleted file mode 100644
index b6cc53095..000000000
--- a/sci-libs/clfft/files/clfft-2.4-client_CMakeLists.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Upstream patch to change the client binary's name to clFFT-client.
-Remove for clfft-9999 as soon as develop branch is merged into master.
-
-
-From f3cbd72953094217dfeb41c4e2a328d4b4a494e0 Mon Sep 17 00:00:00 2001
-From: Marius Brehler <marius.brehler@tu-dortmund.de>
-Date: Wed, 18 Feb 2015 09:15:13 +0100
-Subject: [PATCH] Rename Client to clFFT-client
-
----
- src/client/CMakeLists.txt | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/client/CMakeLists.txt b/src/client/CMakeLists.txt
-index fdf209f..3b38b95 100644
---- a/src/client/CMakeLists.txt
-+++ b/src/client/CMakeLists.txt
-@@ -43,15 +43,15 @@ endif( )
- # Include standard OpenCL headers
- include_directories( ${Boost_INCLUDE_DIRS} ${OPENCL_INCLUDE_DIRS} ../../../common ${PROJECT_BINARY_DIR}/include ../include )
-
--add_executable( Client ${Client.Files} )
-+add_executable( clFFT-client ${Client.Files} )
-
--target_link_libraries( Client clFFT ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${DL_LIB} )
-+target_link_libraries( clFFT-client clFFT ${Boost_LIBRARIES} ${OPENCL_LIBRARIES} ${DL_LIB} )
-
--set_target_properties( Client PROPERTIES VERSION ${CLFFT_VERSION} )
--set_target_properties( Client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
-+set_target_properties( clFFT-client PROPERTIES VERSION ${CLFFT_VERSION} )
-+set_target_properties( clFFT-client PROPERTIES RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/staging" )
-
- # CPack configuration; include the executable into the package
--install( TARGETS Client
-+install( TARGETS clFFT-client
- RUNTIME DESTINATION bin${SUFFIX_BIN}
- LIBRARY DESTINATION lib${SUFFIX_LIB}
- ARCHIVE DESTINATION lib${SUFFIX_LIB}/import
---
-2.0.4
-
diff --git a/sci-libs/clfft/files/clfft-2.4-fix-cmake-config-install.patch b/sci-libs/clfft/files/clfft-2.4-fix-cmake-config-install.patch
deleted file mode 100644
index 6dd1e15db..000000000
--- a/sci-libs/clfft/files/clfft-2.4-fix-cmake-config-install.patch
+++ /dev/null
@@ -1,128 +0,0 @@
-Upstream patch, with modified destdir
-https://github.com/clMathLibraries/clFFT/pull/88
-
-
-Description: install missing cmake config module
-Author: <kent.knox@amd>
-Origin: upstream
-Forwarded: not-needed
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -283,6 +283,29 @@ else( )
- message( "GoogleTest unit tests will NOT be built" )
- endif( )
-
-+if( BUILD_EXAMPLES )
-+ add_subdirectory( examples )
-+endif()
-+
-+if(WIN32)
-+ set(destdir CMake)
-+else()
-+ set(destdir lib${SUFFIX_LIB}/cmake/clFFT)
-+endif()
-+string(REGEX REPLACE "[^/]+" ".." reldir "${destdir}")
-+configure_file(
-+ ${CMAKE_CURRENT_SOURCE_DIR}/clFFTConfigVersion.cmake.in
-+ ${CMAKE_CURRENT_BINARY_DIR}/clFFTConfigVersion.cmake
-+ @ONLY)
-+configure_file(
-+ ${CMAKE_CURRENT_SOURCE_DIR}/clFFTConfig.cmake.in
-+ ${CMAKE_CURRENT_BINARY_DIR}/clFFTConfig.cmake
-+ @ONLY)
-+install(EXPORT Library DESTINATION ${destdir} FILE clFFTTargets.cmake)
-+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/clFFTConfigVersion.cmake
-+ ${CMAKE_CURRENT_BINARY_DIR}/clFFTConfig.cmake
-+ DESTINATION ${destdir})
-+
- # The following code is setting variables to control the behavior of CPack to generate our
- if( WIN32 )
- set( CPACK_SOURCE_GENERATOR "ZIP" )
-diff --git a/src/clFFTConfig.cmake.in b/src/clFFTConfig.cmake.in
-new file mode 100644
-index 0000000..5b58c35
---- /dev/null
-+++ b/src/clFFTConfig.cmake.in
-@@ -0,0 +1,3 @@
-+include(${CMAKE_CURRENT_LIST_DIR}/clFFTTargets.cmake)
-+get_filename_component(CLFFT_INCLUDE_DIRS ${CMAKE_CURRENT_LIST_DIR}/@reldir@/include ABSOLUTE)
-+set(CLFFT_LIBRARIES clFFT)
-diff --git a/src/clFFTConfigVersion.cmake.in b/src/clFFTConfigVersion.cmake.in
-new file mode 100644
-index 0000000..e358473
---- /dev/null
-+++ b/src/clFFTConfigVersion.cmake.in
-@@ -0,0 +1,46 @@
-+# This is a basic version file for the Config-mode of find_package().
-+# It is used by write_basic_package_version_file() as input file for configure_file()
-+# to create a version-file which can be installed along a config.cmake file.
-+#
-+# The created file sets PACKAGE_VERSION_EXACT if the current version string and
-+# the requested version string are exactly the same and it sets
-+# PACKAGE_VERSION_COMPATIBLE if the current version is >= requested version,
-+# but only if the requested major version is the same as the current one.
-+# The variable CLFFT_VERSION must be set before calling configure_file().
-+
-+
-+set(PACKAGE_VERSION "@CLFFT_VERSION@")
-+
-+if("${PACKAGE_VERSION}" VERSION_LESS "${PACKAGE_FIND_VERSION}" )
-+ set(PACKAGE_VERSION_COMPATIBLE FALSE)
-+else()
-+
-+ if("@CLFFT_VERSION@" MATCHES "^([0-9]+)\\.")
-+ set(CLFFT_VERSION_MAJOR "${CMAKE_MATCH_1}")
-+ else()
-+ set(CLFFT_VERSION_MAJOR "@CLFFT_VERSION@")
-+ endif()
-+
-+ if("${PACKAGE_FIND_VERSION_MAJOR}" STREQUAL "${CLFFT_VERSION_MAJOR}")
-+ set(PACKAGE_VERSION_COMPATIBLE TRUE)
-+ else()
-+ set(PACKAGE_VERSION_COMPATIBLE FALSE)
-+ endif()
-+
-+ if( "${PACKAGE_FIND_VERSION}" STREQUAL "${PACKAGE_VERSION}")
-+ set(PACKAGE_VERSION_EXACT TRUE)
-+ endif()
-+endif()
-+
-+
-+# if the installed or the using project don't have CMAKE_SIZEOF_VOID_P set, ignore it:
-+if("${CMAKE_SIZEOF_VOID_P}" STREQUAL "" OR "@CMAKE_SIZEOF_VOID_P@" STREQUAL "")
-+ return()
-+endif()
-+
-+# check that the installed version has the same 32/64bit-ness as the one which is currently searching:
-+if(NOT "${CMAKE_SIZEOF_VOID_P}" STREQUAL "@CMAKE_SIZEOF_VOID_P@")
-+ math(EXPR installedBits "@CMAKE_SIZEOF_VOID_P@ * 8")
-+ set(PACKAGE_VERSION "${PACKAGE_VERSION} (${installedBits}bit)")
-+ set(PACKAGE_VERSION_UNSUITABLE TRUE)
-+endif()
-diff --git a/src/library/CMakeLists.txt b/src/library/CMakeLists.txt
-index 63ac0f9..0d400d8 100644
---- a/src/library/CMakeLists.txt
-+++ b/src/library/CMakeLists.txt
-@@ -95,6 +95,7 @@ endif( )
-
- # CPack configuration; include the executable into the package
- install( TARGETS clFFT
-+ EXPORT Library
- RUNTIME DESTINATION bin${SUFFIX_BIN}
- LIBRARY DESTINATION lib${SUFFIX_LIB}
- ARCHIVE DESTINATION lib${SUFFIX_LIB}/import
-diff --git a/src/statTimer/CMakeLists.txt b/src/statTimer/CMakeLists.txt
-index a635bf1..3dc026f 100644
---- a/src/statTimer/CMakeLists.txt
-+++ b/src/statTimer/CMakeLists.txt
-@@ -80,6 +80,7 @@ endif( )
-
- # CPack configuration; include the executable into the package
- install( TARGETS StatTimer
-+ EXPORT Library
- RUNTIME DESTINATION bin${SUFFIX_BIN}
- LIBRARY DESTINATION lib${SUFFIX_LIB}
- ARCHIVE DESTINATION lib${SUFFIX_LIB}/import
---
-2.1.4
-
diff --git a/sci-libs/clfft/files/clfft-2.4-scripts_perf_CMakeLists.patch b/sci-libs/clfft/files/clfft-2.4-scripts_perf_CMakeLists.patch
deleted file mode 100644
index eec9169c1..000000000
--- a/sci-libs/clfft/files/clfft-2.4-scripts_perf_CMakeLists.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Upstream patch to install Python scripts to /usr/share/clfft and not to /usr/bin.
-Remove for clfft-9999 as soon as develop branch is merged into master.
-
-From 37b1f443e516f0a87c4a728cac8291148bb31b72 Mon Sep 17 00:00:00 2001
-From: Marius Brehler <marius.brehler@tu-dortmund.de>
-Date: Wed, 18 Feb 2015 08:59:06 +0100
-Subject: [PATCH] Install scripts/perf to share/clFFT on non WIN32
- systems
-
----
- src/scripts/perf/CMakeLists.txt | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/src/scripts/perf/CMakeLists.txt b/src/scripts/perf/CMakeLists.txt
-index 3733789..ca45b92 100644
---- a/src/scripts/perf/CMakeLists.txt
-+++ b/src/scripts/perf/CMakeLists.txt
-@@ -20,5 +20,8 @@ set(GRAPHING_SCRIPTS measurePerformance.py
- errorHandler.py
- performanceUtility.py
- )
--
--install( FILES ${GRAPHING_SCRIPTS} DESTINATION bin${SUFFIX_BIN} )
-\ No newline at end of file
-+if( WIN32 )
-+ install( FILES ${GRAPHING_SCRIPTS} DESTINATION bin${SUFFIX_BIN} )
-+else ( )
-+ install( FILES ${GRAPHING_SCRIPTS} DESTINATION share/clFFT )
-+endif( )
-\ No newline at end of file
---
-2.0.4
-