aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-05-11 22:52:01 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-05-11 22:52:01 +0200
commitb4d718826142afae7cc76670a8d0b82e9f225502 (patch)
treef898c145034b958691bcc23cc47a780a18b6d7d8 /sci-libs/clfft
parentsci-libs/clrng: Initial ebuild (diff)
downloadsci-b4d718826142afae7cc76670a8d0b82e9f225502.tar.gz
sci-b4d718826142afae7cc76670a8d0b82e9f225502.tar.bz2
sci-b4d718826142afae7cc76670a8d0b82e9f225502.zip
sci-libs/clfft: clfft-9999 points to develop branch
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-libs/clfft')
-rw-r--r--sci-libs/clfft/ChangeLog6
l---------sci-libs/clfft/clfft-0.9999.ebuild1
-rw-r--r--sci-libs/clfft/clfft-9999.ebuild16
3 files changed, 18 insertions, 5 deletions
diff --git a/sci-libs/clfft/ChangeLog b/sci-libs/clfft/ChangeLog
index e97dacd3c..92fa54017 100644
--- a/sci-libs/clfft/ChangeLog
+++ b/sci-libs/clfft/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*clfft-0.9999 (11 May 2015)
+
+ 11 May 2015; Marius Brehler <marbre@linux.sungazer.de> +clfft-0.9999.ebuild,
+ clfft-9999.ebuild:
+ clfft-9999 points to develop branch
+
04 Apr 2015; Marius Brehler <marbre@linux.sungazer.de>
files/clfft-client_CMakeLists.patch,
files/clfft-scripts_perf_CMakeLists.patch:
diff --git a/sci-libs/clfft/clfft-0.9999.ebuild b/sci-libs/clfft/clfft-0.9999.ebuild
new file mode 120000
index 000000000..b6c165da9
--- /dev/null
+++ b/sci-libs/clfft/clfft-0.9999.ebuild
@@ -0,0 +1 @@
+clfft-9999.ebuild \ No newline at end of file
diff --git a/sci-libs/clfft/clfft-9999.ebuild b/sci-libs/clfft/clfft-9999.ebuild
index 850f8b0a4..994dad99c 100644
--- a/sci-libs/clfft/clfft-9999.ebuild
+++ b/sci-libs/clfft/clfft-9999.ebuild
@@ -11,10 +11,13 @@ MY_PN="clFFT"
DESCRIPTION="A software library containing FFT functions written in OpenCL"
HOMEPAGE="https://github.com/clMathLibraries/clFFT"
-if [ ${PV} == "9999" ] ; then
+if [ ${PV} == "9999" ] || [ ${PV} == "0.9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/clMathLibraries/${MY_PN}.git git://github.com/clMathLibraries/${MY_PN}.git"
S="${WORKDIR}/${P}/src"
+ if [ ${PV} == "9999" ]; then
+ EGIT_BRANCH="develop"
+ fi
else
SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
@@ -39,10 +42,13 @@ DEPEND="${RDEPEND}"
# Therefore src_test() won't execute any test.
RESTRICT="test"
-PATCHES=(
- "${FILESDIR}"/clfft-client_CMakeLists.patch
- "${FILESDIR}"/clfft-scripts_perf_CMakeLists.patch
-)
+# Patches are only needed for the recent master and releases <= 2.4
+if [ ${PV} != "9999" ]; then
+ PATCHES=(
+ "${FILESDIR}"/clfft-client_CMakeLists.patch
+ "${FILESDIR}"/clfft-scripts_perf_CMakeLists.patch
+ )
+fi
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then