aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-16 15:28:59 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-16 15:28:59 -0700
commite1dfb28270e6503cac882c24478782b8eb932cec (patch)
tree05749a2c11b8c5811f3020cfb9927e06630430b4 /sci-libs/coinor-alps
parentsci-libs/coinor-cbc: Initial import (diff)
downloadsci-e1dfb28270e6503cac882c24478782b8eb932cec.tar.gz
sci-e1dfb28270e6503cac882c24478782b8eb932cec.tar.bz2
sci-e1dfb28270e6503cac882c24478782b8eb932cec.zip
sci-libs/coinor-alps: Initial import
(Portage version: 2.2.01.20757-prefix/git/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'sci-libs/coinor-alps')
-rw-r--r--sci-libs/coinor-alps/ChangeLog9
-rw-r--r--sci-libs/coinor-alps/Manifest1
-rw-r--r--sci-libs/coinor-alps/coinor-alps-1.4.2.ebuild66
-rw-r--r--sci-libs/coinor-alps/metadata.xml13
4 files changed, 89 insertions, 0 deletions
diff --git a/sci-libs/coinor-alps/ChangeLog b/sci-libs/coinor-alps/ChangeLog
new file mode 100644
index 000000000..ac29583c4
--- /dev/null
+++ b/sci-libs/coinor-alps/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/coinor-alps
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*coinor-alps-1.4.2 (16 Jul 2012)
+
+ 16 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +coinor-alps-1.4.2.ebuild,
+ +metadata.xml:
+ sci-libs/coinor-alps: Initial import
diff --git a/sci-libs/coinor-alps/Manifest b/sci-libs/coinor-alps/Manifest
new file mode 100644
index 000000000..0e1c0a8fc
--- /dev/null
+++ b/sci-libs/coinor-alps/Manifest
@@ -0,0 +1 @@
+DIST Alps-1.4.2.tgz 5038954 SHA256 4767d2607a92fa8114156eaabfb94ebd55e22b8a12d42db91a6d83b7e9d60a91 SHA512 2dd6bd06b20a3c6e56be13e030a89f8c7cd038432f62eb42fde9e332f2f621a7e0caf80ffcc7fa2b3905e2920824c3e597349d0a7403e8e44c839e94bf7df888 WHIRLPOOL 5ec00126c214137cd8ec5911d0f7d43558f991c6f9e0df5e2af0c09e2e388da2fedde821f26105676dc9ef598b0a983ef5440db86c4b3724c2c5d39a15ba3030
diff --git a/sci-libs/coinor-alps/coinor-alps-1.4.2.ebuild b/sci-libs/coinor-alps/coinor-alps-1.4.2.ebuild
new file mode 100644
index 000000000..f934c8521
--- /dev/null
+++ b/sci-libs/coinor-alps/coinor-alps-1.4.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools-utils multilib
+
+MYPN=Alps
+
+DESCRIPTION="COIN-OR Framework for implementing parallel graph search algorithms"
+HOMEPAGE="https://projects.coin-or.org/CHiPPS/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="sci-libs/coinor-utils
+ sci-libs/coinor-clp"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # as-needed fix
+ # hack to avoid eautoreconf (coinor has its own weird autotools)
+ sed -i \
+ -e 's:\(libAlps_la_LIBADD.*=\).*:\1 @ALPSLIB_LIBS@:g' \
+ src/Makefile.in || die
+ # bug for later versions of subversions
+ sed -i \
+ -e 's/xexported/xexported -a "x$svn_rev_tmp" != "xUnversioned directory"/' \
+ configure
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc dot)
+ )
+ PKG_CONFIG_PATH+="${ED}"/usr/$(get_libdir)/pkgconfig \
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo doxydoc)
+}
+
+src_test() {
+ pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null || die
+ emake test
+ popd > /dev/null || die
+}
+
+src_install() {
+ use doc && HTML_DOC=("${AUTOTOOLS_BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-alps/metadata.xml b/sci-libs/coinor-alps/metadata.xml
new file mode 100644
index 000000000..56d981f3f
--- /dev/null
+++ b/sci-libs/coinor-alps/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ CHiPPS is the COIN-OR High-Performance Parallel Search Framework, a
+ framework for implementing parallel algorithms based on tree
+ search. The current CHiPPS architecture consists of three
+ layers. The Abstract Library for Parallel Search (ALPS) is the base
+ layer of a hierarchy consisting of implementations of various tree
+ search algorithms for specific problem types.
+</longdescription>
+</pkgmetadata>