aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-16 15:12:22 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-16 15:12:22 -0700
commitf65601afd9f5e7596deae265b59b51a1873cb4db (patch)
treebbc8886fe81f29189399eff3b26d05edee1ff06a /sci-libs/coinor-osi
parentsci-libs/coinor-utils: Initial import (diff)
downloadsci-f65601afd9f5e7596deae265b59b51a1873cb4db.tar.gz
sci-f65601afd9f5e7596deae265b59b51a1873cb4db.tar.bz2
sci-f65601afd9f5e7596deae265b59b51a1873cb4db.zip
sci-libs/coinor-osi: Initial import
(Portage version: 2.2.01.20757-prefix/git/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'sci-libs/coinor-osi')
-rw-r--r--sci-libs/coinor-osi/ChangeLog9
-rw-r--r--sci-libs/coinor-osi/Manifest1
-rw-r--r--sci-libs/coinor-osi/coinor-osi-0.105.3.ebuild75
-rw-r--r--sci-libs/coinor-osi/metadata.xml15
4 files changed, 100 insertions, 0 deletions
diff --git a/sci-libs/coinor-osi/ChangeLog b/sci-libs/coinor-osi/ChangeLog
new file mode 100644
index 000000000..75f8f4654
--- /dev/null
+++ b/sci-libs/coinor-osi/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/coinor-osi
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*coinor-osi-0.105.3 (16 Jul 2012)
+
+ 16 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +coinor-osi-0.105.3.ebuild, +metadata.xml:
+ sci-libs/coinor-osi: Initial import
diff --git a/sci-libs/coinor-osi/Manifest b/sci-libs/coinor-osi/Manifest
new file mode 100644
index 000000000..44a4a925e
--- /dev/null
+++ b/sci-libs/coinor-osi/Manifest
@@ -0,0 +1 @@
+DIST Osi-0.105.3.tgz 3433377 SHA256 3557c35e5534122aa4e2e733cf18b2dec86f7afd728297db5b1396e1785d0299 SHA512 14517293a8e0dc9c9dc96170851146fbc006f4f6cca4fd76dd24f247e15833d916ef02a9462836ef4fdea7b42af98718641da8725fa6d365deffebf2f56d5eb9 WHIRLPOOL 3e8d9c209999175d69b6c40ab3d3e51561b1975bde9a4d3a177a82180fff802ade6269e928decaa35340529844ac8dcc83926dd3633fc0d329a91920d8474d95
diff --git a/sci-libs/coinor-osi/coinor-osi-0.105.3.ebuild b/sci-libs/coinor-osi/coinor-osi-0.105.3.ebuild
new file mode 100644
index 000000000..cd3ea704b
--- /dev/null
+++ b/sci-libs/coinor-osi/coinor-osi-0.105.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools-utils multilib
+
+MYPN=Osi
+
+DESCRIPTION="COIN-OR Open Solver Interface"
+HOMEPAGE="https://projects.coin-or.org/Osi/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples glpk static-libs test"
+
+RDEPEND="sci-libs/coinor-utils
+ glpk? ( sci-mathematics/glpk )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # as-needed fix
+ # hack to avoid eautoreconf (coinor has its own weird autotools)
+ sed -i \
+ -e 's:\(libOsi.*_la_LIBADD.*=\).*:\1 $(top_builddir)/src/Osi/libOsi.la:g' \
+ src/Osi*/Makefile.in || die
+ sed -i \
+ -e 's:\(libOsi_la_LIBADD.*=\).*:\1 @OSILIB_LIBS@:g' \
+ src/Osi/Makefile.in || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc dot)
+ )
+ if use glpk; then
+ myeconfargs+=(
+ --with-glpk-incdir="${EPREFIX}"/usr/include
+ --with-glpk-lib=-lglpk
+ )
+ else
+ myeconfargs+=( --without-glpk )
+ fi
+ PKG_CONFIG_PATH+="${ED}"/usr/$(get_libdir)/pkgconfig \
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo doxydoc)
+}
+
+src_test() {
+ pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null || die
+ emake test
+ popd > /dev/null || die
+}
+
+src_install() {
+ use doc && HTML_DOC=("${AUTOTOOLS_BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-osi/metadata.xml b/sci-libs/coinor-osi/metadata.xml
new file mode 100644
index 000000000..3bcaa06c3
--- /dev/null
+++ b/sci-libs/coinor-osi/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The COIN-OR Open Solver Interface is a uniform API for interacting with
+ callable solver libraries. It supports linear programming solvers as
+ well as the ability to "finish off" a mixed-integer problem calling the
+ solver library's MIP solver.
+</longdescription>
+<use>
+ <flag name='glpk'>Enable GNU Linear Programming Kit
+ <pkg>sci-mathematics/glpk</pkg> support</flag>
+</use>
+</pkgmetadata>