aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2011-01-17 21:28:13 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2011-01-17 21:28:13 +0100
commit8e6c5d2b654778454a0e8964fa4df6f19bd36ca4 (patch)
treea80130e4a40cb959592d27010642214b3c7bc6d6 /sci-libs/etsf_io
parentA bigDFT ebuild for sci-physics/abinit; not the latest version but the abinit... (diff)
downloadsci-8e6c5d2b654778454a0e8964fa4df6f19bd36ca4.tar.gz
sci-8e6c5d2b654778454a0e8964fa4df6f19bd36ca4.tar.bz2
sci-8e6c5d2b654778454a0e8964fa4df6f19bd36ca4.zip
An ETSF IO ebuild for sci-physics/abinit
Diffstat (limited to 'sci-libs/etsf_io')
-rw-r--r--sci-libs/etsf_io/ChangeLog10
-rw-r--r--sci-libs/etsf_io/Manifest3
-rw-r--r--sci-libs/etsf_io/etsf_io-1.0.3.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/etsf_io/ChangeLog b/sci-libs/etsf_io/ChangeLog
new file mode 100644
index 000000000..e657c3e12
--- /dev/null
+++ b/sci-libs/etsf_io/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/etsf_io
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*etsf_io-1.0.3 (17 Jan 2011)
+
+ 17 Jan 2011; Honza Macháček <Hloupy.Honza@centrum.cz>
+ +etsf_io-1.0.3.ebuild:
+ An ETSF IO ebuild for sci-physics/abinit
+
diff --git a/sci-libs/etsf_io/Manifest b/sci-libs/etsf_io/Manifest
new file mode 100644
index 000000000..8c3064e59
--- /dev/null
+++ b/sci-libs/etsf_io/Manifest
@@ -0,0 +1,3 @@
+DIST etsf_io-1.0.3.tar.gz 453734 RMD160 df90acd34b0de104a07844ae2c9694edf27519c6 SHA1 ab3c4cb22ea2fc2498b396f186f221edd2463fcc SHA256 a02ead44b9634bdb6e47e50d76f35d56c10df468743e6fe5259c0dc478f7b32e
+EBUILD etsf_io-1.0.3.ebuild 929 RMD160 0257864226359bac808ab9a108f19bb8495820c7 SHA1 6c1ccab966ede6f6468ee28414a3e759dc06dc93 SHA256 3d701906e2599221e493cae8149dfa5f4c2c3f63764a755d0ffea69f255bf09f
+MISC ChangeLog 274 RMD160 31ff09d34ecd11d6deccdd8bd8045140429795a8 SHA1 59749fbcebdf10b6f6ad44a3046fc45b69bbed68 SHA256 8eafc2bb689f87f93df639b5fd7f7befe360c636f5eaf5e5a7bc3b0472ab5987
diff --git a/sci-libs/etsf_io/etsf_io-1.0.3.ebuild b/sci-libs/etsf_io/etsf_io-1.0.3.ebuild
new file mode 100644
index 000000000..4392a2dd1
--- /dev/null
+++ b/sci-libs/etsf_io/etsf_io-1.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A library of F90 routines to read/write the ETSF file format"
+SRC_URI="http://www.etsf.eu/sites/default/files/${P}.tar.gz"
+HOMEPAGE="http://www.etsf.eu/resources/software/libraries_and_tools"
+
+LICENSE="LGPL"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sci-libs/netcdf[fortran]"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ tar xf ${DISTDIR}/${A}
+}
+
+src_configure() {
+ # fortran 90 uses FCFLAGS
+ export FCFLAGS="${FFLAGS:--O2}"
+ econf \
+ --prefix=/usr \
+ $(use_enable examples build-tutorials) \
+ --with-netcdf-ldflags="-L/usr/lib -lnetcdff" \
+ --with-moduledir=/usr/lib/finclude
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README NEWS COPYING AUTHORS INSTALL ChangeLog || die "dodoc failed"
+}