aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tom111@gmx.de>2009-11-24 20:56:54 +0100
committerThomas Kahle <tom111@gmx.de>2009-11-24 20:57:35 +0100
commit813615a5854ff1f875413ea87deba0cfe5c9544d (patch)
treeaa3d3ea1e6392446289ae6641bd17049c47533fe /sci-libs/factory/factory-3.1.0.ebuild
parentNew package sci-libs/libfac (diff)
downloadsci-813615a5854ff1f875413ea87deba0cfe5c9544d.tar.gz
sci-813615a5854ff1f875413ea87deba0cfe5c9544d.tar.bz2
sci-813615a5854ff1f875413ea87deba0cfe5c9544d.zip
New package: sci-libs/factory
Dependency of sci-libs/libfac
Diffstat (limited to 'sci-libs/factory/factory-3.1.0.ebuild')
-rw-r--r--sci-libs/factory/factory-3.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/factory/factory-3.1.0.ebuild b/sci-libs/factory/factory-3.1.0.ebuild
new file mode 100644
index 000000000..ecc5b22e6
--- /dev/null
+++ b/sci-libs/factory/factory-3.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+DESCRIPTION="factory is a C++ library for representing multivariate polynomials"
+
+HOMEPAGE="http://www.mathematik.uni-kl.de/pub/Math/Singular/Factory"
+
+SRC_URI="ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-3-1-0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="singular"
+
+DEPEND="dev-libs/gmp
+ >=dev-libs/ntl-5.4.1"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/factory"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/patch-3.1.0b || die "patching failed"
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}"
+
+ econf --prefix="${D}/usr" \
+ $(use_with singular Singular) || die "econf failed"
+
+ # Not doing this explicitly might trigger a race condition
+ emake factoryconf.h || die "make failed"
+ emake all || die "make failed"
+}
+
+src_install() {
+ cd "${S}"
+ # Another race condition when creating dirs with -j3
+ emake -j1 install || die "Install failed"
+} \ No newline at end of file