aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-20 13:20:09 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-20 13:20:09 +0100
commit490fa66ffa51dcf074eca92c85880a803e689377 (patch)
tree0d1b1895bbe062fb8827a5ec6eeefdf04f0d5fb0 /sci-libs/ghmm/files
parentapp-text/jabref: Moved jabref-2.9.2 to x86. (diff)
downloadsci-490fa66ffa51dcf074eca92c85880a803e689377.tar.gz
sci-490fa66ffa51dcf074eca92c85880a803e689377.tar.bz2
sci-490fa66ffa51dcf074eca92c85880a803e689377.zip
sci-libs/ghmm: Drop obsolete tools, #163; correctly support python modules; add optional support for gsl and lapack
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-libs/ghmm/files')
-rw-r--r--sci-libs/ghmm/files/ghmm-9999-link.patch24
-rw-r--r--sci-libs/ghmm/files/ghmm-9999-obsolete.patch13
-rw-r--r--sci-libs/ghmm/files/ghmm-9999-out-of-source.patch40
-rw-r--r--sci-libs/ghmm/files/ghmm-9999-respect.patch12
4 files changed, 89 insertions, 0 deletions
diff --git a/sci-libs/ghmm/files/ghmm-9999-link.patch b/sci-libs/ghmm/files/ghmm-9999-link.patch
new file mode 100644
index 000000000..9b4e919ec
--- /dev/null
+++ b/sci-libs/ghmm/files/ghmm-9999-link.patch
@@ -0,0 +1,24 @@
+Index: tools/Makefile.am
+===================================================================
+--- tools/Makefile.am (revision 2332)
++++ tools/Makefile.am (working copy)
+@@ -23,5 +23,5 @@
+ smix_hmm_SOURCES = smix_hmm.c
+ smo2xml_SOURCES = smo2xml.c
+
+-LDADD = $(top_builddir)/ghmm/.libs/libghmm.a
++LDADD = $(top_builddir)/ghmm/libghmm.la
+ bin_SCRIPTS = ghmm-config
+Index: tests/Makefile.am
+===================================================================
+--- tests/Makefile.am (revision 2332)
++++ tests/Makefile.am (working copy)
+@@ -34,7 +34,7 @@
+ read_fa \
+ mcmc
+
+-LDADD = $(top_builddir)/ghmm/.libs/libghmm.a
++LDADD = $(top_builddir)/ghmm/libghmm.la
+
+ TESTS_ENVIRONMENT = GHMM_SILENT_TESTS
+ TESTS = root_finder_test \
diff --git a/sci-libs/ghmm/files/ghmm-9999-obsolete.patch b/sci-libs/ghmm/files/ghmm-9999-obsolete.patch
new file mode 100644
index 000000000..2e6be54d0
--- /dev/null
+++ b/sci-libs/ghmm/files/ghmm-9999-obsolete.patch
@@ -0,0 +1,13 @@
+Index: configure.in
+===================================================================
+--- configure.in (revision 2332)
++++ configure.in (working copy)
+@@ -293,7 +293,7 @@
+ CFLAGS="$CFLAGS $LIBXML2_CFLAGS"
+
+ dnl final configuration
+-SUBDIRS="ghmm tools tests"
++SUBDIRS="ghmm"
+
+ dnl python wrapper can be switched on or off
+ AC_ARG_WITH(python,
diff --git a/sci-libs/ghmm/files/ghmm-9999-out-of-source.patch b/sci-libs/ghmm/files/ghmm-9999-out-of-source.patch
new file mode 100644
index 000000000..6197d9ba1
--- /dev/null
+++ b/sci-libs/ghmm/files/ghmm-9999-out-of-source.patch
@@ -0,0 +1,40 @@
+Index: tools/Makefile.am
+===================================================================
+--- tools/Makefile.am (revision 2332)
++++ tools/Makefile.am (working copy)
+@@ -12,7 +12,7 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+ BUILT_SOURCES =
+-INCLUDES = -I$(top_srcdir)
++INCLUDES = -I$(top_srcdir) -I$(top_builddir)/ghmm
+
+ bin_PROGRAMS = probdist cluster scluster smix_hmm $(OBSOLETE_TOOLS)
+ EXTRA_PROGRAMS = smo2xml
+Index: tests/Makefile.am
+===================================================================
+--- tests/Makefile.am (revision 2332)
++++ tests/Makefile.am (working copy)
+@@ -15,7 +15,7 @@
+ MAINTAINERCLEANFILES = Makefile.in
+ # stuff from dejagnu
+
+-INCLUDES=-I$(top_srcdir)
++INCLUDES=-I$(top_srcdir) -I$(top_builddir)/ghmm
+
+ #these tests will not be installed
+ # in progress: test_sdfoba nullmodel ciscreen test_sdmodel
+Index: ghmmwrapper/Makefile.am
+===================================================================
+--- ghmmwrapper/Makefile.am (revision 2332)
++++ ghmmwrapper/Makefile.am (working copy)
+@@ -47,7 +47,9 @@
+ testdata/model_label.xml \
+ testdata/tiny.txt.sqd
+
++INCLUDES=-I$(top_builddir)
+
++
+ EXTRA_DIST = ${SWIG_INTERFACE_FILES} ${EXTENSION_C_FILES} ${PYTHON_FILES} ${PYTHON_GATO_FILES} ${TESTDATA_FILES}
+
+ all: setup.py ghmm.py ${SWIG_INTERFACE_FILES}
diff --git a/sci-libs/ghmm/files/ghmm-9999-respect.patch b/sci-libs/ghmm/files/ghmm-9999-respect.patch
new file mode 100644
index 000000000..09c8721c9
--- /dev/null
+++ b/sci-libs/ghmm/files/ghmm-9999-respect.patch
@@ -0,0 +1,12 @@
+Index: ghmmwrapper/setup.py
+===================================================================
+--- ghmmwrapper/setup.py (revision 2332)
++++ ghmmwrapper/setup.py (working copy)
+@@ -48,7 +48,6 @@
+ include_dirs = ['..'],
+ library_dirs = ['../ghmm/.libs'],
+ libraries = ['ghmm', 'm', 'pthread', 'xml2', 'z'],
+- extra_compile_args = ["-O2", "-pipe", "-Wall"], # -g might help debugging
+ depends = ['wrapper_alphabet.i', 'wrapper_cmodel.i', 'wrapper_cseq.i',
+ 'wrapper_dmodel.i', 'wrapper_dpmodel.i', 'wrapper_dpseq.i',
+ 'wrapper_dseq.i', 'wrapper_xmlfile.i']