aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <francois@vrooom.(none)>2009-11-09 16:42:43 +1300
committerFrançois Bissey <francois@vrooom.(none)>2009-11-09 16:44:52 +1300
commit15885434cea21cefdd9f8cc547c3f5ef7455ed18 (patch)
treee4c32f29e414c5d7ddf50a5a0d73e158b362a2f7 /sci-libs/givaro/givaro-3.2.13.ebuild
parentsci-libs/cctbx version bump (diff)
downloadsci-15885434cea21cefdd9f8cc547c3f5ef7455ed18.tar.gz
sci-15885434cea21cefdd9f8cc547c3f5ef7455ed18.tar.bz2
sci-15885434cea21cefdd9f8cc547c3f5ef7455ed18.zip
givaro bump
Diffstat (limited to 'sci-libs/givaro/givaro-3.2.13.ebuild')
-rw-r--r--sci-libs/givaro/givaro-3.2.13.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/givaro/givaro-3.2.13.ebuild b/sci-libs/givaro/givaro-3.2.13.ebuild
new file mode 100644
index 000000000..bd533de97
--- /dev/null
+++ b/sci-libs/givaro/givaro-3.2.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="C++ library for arithmetic and algebraic computations"
+HOMEPAGE="http://ljk.imag.fr/CASYS/LOGICIELS/givaro/"
+SRC_URI="http://ljk.imag.fr/CASYS/LOGICIELS/givaro/Downloads/${P}.tar.gz"
+
+#### Remove the following line when moving this ebuild to the main tree!
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE=""
+
+RDEPEND=">=dev-libs/gmp-4.1-r1"
+DEPEND="${RDEPEND}"
+
+src_configure(){
+ econf "--enable-shared" || die "Configure failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}
+
+pkg_postinst() {
+ elog "The givaro ebuild is still under development."
+ elog "Help us improve the ebuild in:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=227803"
+}