aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <francois@vrooom.(none)>2009-11-23 15:01:12 +1300
committerFrançois Bissey <francois@vrooom.(none)>2009-11-23 15:01:49 +1300
commit332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd (patch)
treedc40fa4ecb7a7228702b05dbf718c41c6a65b98f /sci-libs/iml
parentFix openib.init.d and env.d (diff)
downloadsci-332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd.tar.gz
sci-332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd.tar.bz2
sci-332f8a4a9fa38f5891cb62d6bf78573f2d53a0dd.zip
Importing iml-1.0.3
Diffstat (limited to 'sci-libs/iml')
-rw-r--r--sci-libs/iml/ChangeLog11
-rw-r--r--sci-libs/iml/Manifest6
-rw-r--r--sci-libs/iml/files/fix-undefined-symbol.patch11
-rw-r--r--sci-libs/iml/files/iml-1.0.3-cblas.patch41
-rw-r--r--sci-libs/iml/iml-1.0.3.ebuild43
-rw-r--r--sci-libs/iml/metadata.xml6
6 files changed, 118 insertions, 0 deletions
diff --git a/sci-libs/iml/ChangeLog b/sci-libs/iml/ChangeLog
new file mode 100644
index 000000000..7310d1e95
--- /dev/null
+++ b/sci-libs/iml/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/iml
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*iml-1.0.3 (23 Nov 2009)
+
+ 23 Nov 2009; François Bissey <f.r.bissey@massey.ac.nz> +iml-1.0.3.ebuild,
+ +files/iml-1.0.3-cblas.patch, +files/fix-undefined-symbol.patch,
+ +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/iml/Manifest b/sci-libs/iml/Manifest
new file mode 100644
index 000000000..50a692a26
--- /dev/null
+++ b/sci-libs/iml/Manifest
@@ -0,0 +1,6 @@
+AUX fix-undefined-symbol.patch 371 RMD160 eacff26ecc4c551d75a28bb803a2f7212974fdb2 SHA1 2a39ae5a6d7942dd9a3c771396b8393d6cd82c65 SHA256 d5d907e145ea859808d8a6e2083167f7d35548456df792ee1f85bd1e2dc4007a
+AUX iml-1.0.3-cblas.patch 1365 RMD160 37c1edb0fc7ca4d2d6d9cdfe5f48252b12ab0a79 SHA1 9098b0cb60e1981f6c4d33dcaa9047e16882a380 SHA256 15353191da84e3d7940982878a30c75ec440053416449544f52e46e9f971b70c
+DIST iml-1.0.3.tar.gz 395160 RMD160 6b845c476158ab977226a69fd8baa3e95bf8d3a8 SHA1 3783e6e0c5aacd0113f30eb731d12de981de6a5e SHA256 fc626debbf8f84689398f4b941a6c1ded0910eea4388e169bf63c48e257b0395
+EBUILD iml-1.0.3.ebuild 933 RMD160 7d095e4f183d299b8285131efc368b9dd213accb SHA1 bb0b623a496619875374f4b560a4154887ca7afe SHA256 eee27a4501218a3845f939d935c37e4f6ae51097af9a35aed14de5f8b3da0eca
+MISC ChangeLog 318 RMD160 6beb2c18b9914836fa1c6d10489a3852f70e415c SHA1 da611d76c5d8b5c7f4792f28c6b1b2638bfe787c SHA256 c1616b2ac3672e882d66f986700fcb678ab33f76002885111ddbb954fd5fe284
+MISC metadata.xml 338 RMD160 e335411f4c21e57fb20107a6cd592fe4aeed2654 SHA1 795d76cd1ed1bff78c84e203bbae1553046d5999 SHA256 dad4bc6f829380868f8827b2bd046c3862783d4744c94e47c082634a7b66e1d9
diff --git a/sci-libs/iml/files/fix-undefined-symbol.patch b/sci-libs/iml/files/fix-undefined-symbol.patch
new file mode 100644
index 000000000..1521d1536
--- /dev/null
+++ b/sci-libs/iml/files/fix-undefined-symbol.patch
@@ -0,0 +1,11 @@
+--- nullspace.c.orig 2008-08-12 15:17:18.000000000 +0200
++++ nullspace.c 2008-08-12 15:12:15.000000000 +0200
+@@ -253,7 +253,7 @@
+ for (i = 0; i < m; i++) {
+ for (j = 0; j < m; j++)
+ mpz_init_set_ui(mp_N[i * m + j], 0);
+- mpz_init_ui(mp_N[i * m + i], 1);
++ mpz_init_set_ui(mp_N[i * m + i], 1);
+ }
+ *mp_N_pass = mp_N;
+ } else { /* r>0 and s>0 */
diff --git a/sci-libs/iml/files/iml-1.0.3-cblas.patch b/sci-libs/iml/files/iml-1.0.3-cblas.patch
new file mode 100644
index 000000000..c9a6a1faa
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.3-cblas.patch
@@ -0,0 +1,41 @@
+--- configure.ac.orig 2009-11-23 09:30:12.000000000 +1300
++++ configure.ac 2009-11-23 11:35:59.000000000 +1300
+@@ -3,6 +3,7 @@
+ AC_PREREQ(2.59)
+ AC_INIT(IML, 1.0.3)
+ AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_MACRO_DIR(config)
+ AM_CONFIG_HEADER(config.h:config-h.in)
+ AC_CONFIG_SRCDIR([src/RNSop.c])
+ AM_INIT_AUTOMAKE
+@@ -55,11 +56,18 @@
+ respectively when running configure.
+ )])
+
+-IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
+-ATLAS not found!
+-ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.
+-)])
++AC_CHECK_HEADERS([cblas.h],
++ [cblas_headers_found=yes; break;])
++
++AS_IF([test "x$cblas_headers_found" != "xyes"],
++ [AC_MSG_ERROR([Unable to find the cblas headers check your installation])])
++
++AC_ARG_WITH(cblas-lib,
++ AC_HELP_STRING([--with-cblas-lib=<lib>],[Specify the flags for cblas.]),
++ with_cblas_lib=$withval)
++ATLAS_LIBS="$with_cblas_lib"
+
++AC_SUBST(ATLAS_LIBS)
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(ac_aux_dir)
+
+--- Makefile.am~ 2009-11-23 11:38:44.000000000 +1300
++++ Makefile.am 2009-11-23 11:38:44.000000000 +1300
+@@ -1,3 +1,5 @@
++ACLOCAL_AMFLAGS = -I config
++
+ EXTRA_DIST = bootstrap
+
+ SUBDIRS = repl config src doc tests examples
diff --git a/sci-libs/iml/iml-1.0.3.ebuild b/sci-libs/iml/iml-1.0.3.ebuild
new file mode 100644
index 000000000..e1dd2d0c7
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND="dev-util/pkgconfig
+ dev-libs/gmp
+ virtual/cblas"
+RDEPEND="dev-libs/gmp
+ virtual/cblas"
+
+src_prepare() {
+ # do not need atlas specifically any cblas will do...
+ epatch "${FILESDIR}/${P}-cblas.patch"
+ # apply patch supplied by debian bugreport #494819
+ epatch "${FILESDIR}/fix-undefined-symbol.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --with-cblas-lib="$(pkg-config cblas --libs)" \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}
diff --git a/sci-libs/iml/metadata.xml b/sci-libs/iml/metadata.xml
new file mode 100644
index 000000000..c0b40271f
--- /dev/null
+++ b/sci-libs/iml/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>a free library of C source code which implements algorithms for computing exact solutions to dense systems of linear equations over the integers</longdescription>
+</pkgmetadata>