aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-04-03 12:49:54 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-04-03 12:49:54 +0200
commite362f42f3143e43270708ab82b90f2bdb4da2335 (patch)
treeb4cd53fa5b9b9a6b4abd92d207bbd7b00e98ffbf /sci-libs/iml
parentsci-libs/iml: Bump to EAPI=5 (diff)
downloadsci-e362f42f3143e43270708ab82b90f2bdb4da2335.tar.gz
sci-e362f42f3143e43270708ab82b90f2bdb4da2335.tar.bz2
sci-e362f42f3143e43270708ab82b90f2bdb4da2335.zip
sci-libs/iml: Version bump
Package-Manager: portage-2.2.14
Diffstat (limited to 'sci-libs/iml')
-rw-r--r--sci-libs/iml/ChangeLog6
-rw-r--r--sci-libs/iml/Manifest1
-rw-r--r--sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch22
-rw-r--r--sci-libs/iml/iml-1.0.4.ebuild35
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-libs/iml/ChangeLog b/sci-libs/iml/ChangeLog
index c7f949445..c2e50b6f3 100644
--- a/sci-libs/iml/ChangeLog
+++ b/sci-libs/iml/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*iml-1.0.4 (03 Apr 2015)
+
+ 03 Apr 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +files/iml-1.0.4-use-any-cblas-implementation.patch, +iml-1.0.4.ebuild:
+ Version bump
+
03 Apr 2015; Marius Brehler <marbre@linux.sungazer.de> iml-1.0.3-r2.ebuild:
Bump to EAPI=5
diff --git a/sci-libs/iml/Manifest b/sci-libs/iml/Manifest
index 2f658aa1e..3d9e920c6 100644
--- a/sci-libs/iml/Manifest
+++ b/sci-libs/iml/Manifest
@@ -1 +1,2 @@
DIST iml-1.0.3.tar.gz 395160 SHA256 fc626debbf8f84689398f4b941a6c1ded0910eea4388e169bf63c48e257b0395 SHA512 92e76a7c08ca6e425153d8c614783064a80077ad9859e1c1460595b5e29e614c6eaf8b330a5f3c1b564209ca8265f93d8485cd5cb376e96f01dc81bf9751a67a WHIRLPOOL c0b65d570513ee74d1659863005f2922f9e91e423ef5c701b665912a3d1fa9c5c389a9d97a0eabbed3334ac0111e815b37a69748a50326a6100903c5ac521722
+DIST iml-1.0.4.tar.bz2 407347 SHA256 88a310d527d98be0219c98a669336a14e7cebf596b439a4494fdfc1492902fd3 SHA512 21cb4f124b7e06526238aff053eb9249eece9342122ec00e7ab2aec68b1c6298a30bee3dd183e322ad4cce636faa679d11422d7cc72b524d8a9b5936017fd209 WHIRLPOOL 2499d0a0a86dc62cccfc342a10398dd0ee3778a3e601d6ecbf4490493d0de09c409d457ee0b5ea0fe908c507aeb7cf67e78645bcae45eb226b7fa1e8b44f8bf3
diff --git a/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch b/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch
new file mode 100644
index 000000000..3d88a3906
--- /dev/null
+++ b/sci-libs/iml/files/iml-1.0.4-use-any-cblas-implementation.patch
@@ -0,0 +1,22 @@
+Patch to detect ATLAS or cblas. Ported from 1.0.3 to 1.0.4.
+
+Patch by Marius Brehler.
+--- configure.ac
++++ configure.ac
+@@ -76,15 +76,7 @@ location with the options --with-gmp-inc
+ respectively when running configure.
+ )])
+
+-IML_CHECK_CBLAS(,,[AC_MSG_WARN(
+-CBLAS not found!
+-Please make sure that --with-cblas=<linker flags> and optional --with-cblas-include=<path> and --with-cblas-lib=<path> are correctly set.
+-Trying legacy ATLAS configuration.)
+-IML_CHECK_ATLAS(,,[AC_MSG_ERROR(
+-ATLAS not found!
+-ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.)
+-])
+-])
++PKG_CHECK_MODULES([ATLAS], [cblas])
+
+ AC_SUBST(LIBIML_LDFLAGS)
+ AC_SUBST(LDFLAGS)
diff --git a/sci-libs/iml/iml-1.0.4.ebuild b/sci-libs/iml/iml-1.0.4.ebuild
new file mode 100644
index 000000000..8be9c4731
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_AUTORECONF=yes
+AT_M4DIR="config"
+DOCS=( AUTHORS ChangeLog README )
+PATCHES=(
+ "${FILESDIR}"/${P}-use-any-cblas-implementation.patch
+)
+
+src_configure() {
+ myeconfargs=(
+ --with-default="${EPREFIX}"/usr
+ )
+ autotools-utils_src_configure
+}