aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc van der Sluys (AstroFloyd) <AstroFloyd@gmail.com>2012-01-29 18:54:07 +0100
committerMarc van der Sluys (AstroFloyd) <AstroFloyd@gmail.com>2012-01-29 18:54:07 +0100
commitea19de3fb22906309e01bc95b5fab9db89718b2b (patch)
treebaf616540302f638e4fda5b446eb20d90d7bc4f5 /sci-libs/k3match/k3match-1.0.ebuild
parentUpdated Manifest for ndiff-2.00 (diff)
downloadsci-ea19de3fb22906309e01bc95b5fab9db89718b2b.tar.gz
sci-ea19de3fb22906309e01bc95b5fab9db89718b2b.tar.bz2
sci-ea19de3fb22906309e01bc95b5fab9db89718b2b.zip
Added first ebuild for k3match, version 1.0
Diffstat (limited to 'sci-libs/k3match/k3match-1.0.ebuild')
-rw-r--r--sci-libs/k3match/k3match-1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/k3match/k3match-1.0.ebuild b/sci-libs/k3match/k3match-1.0.ebuild
new file mode 100644
index 000000000..bcabe3aa3
--- /dev/null
+++ b/sci-libs/k3match/k3match-1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="*:2.6"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Fast matching of large sets of points in 3D space, in O(N log N) time"
+HOMEPAGE="http://pschella.github.com/k3match/"
+SRC_URI="http://www.astro.ru.nl/~pschella/files/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=" "
+
+DEPEND=">=dev-python/numpy-1.4.0"
+RDEPEND="${DEPEND}"