aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schäfer <gentryx@gmx.de>2014-01-28 16:20:58 +0100
committerAndreas Schäfer <gentryx@gmx.de>2014-01-28 16:20:58 +0100
commite04cfb52aa66b94a027a6362907f0027d15a0f7e (patch)
tree7f6828b67a57d94a053b17fe765caae0d92bfce6 /sci-libs/libgeodecomp/libgeodecomp-9999.ebuild
parentfixed copyright dates and use flag descriptions to make repoman happy (diff)
downloadsci-e04cfb52aa66b94a027a6362907f0027d15a0f7e.tar.gz
sci-e04cfb52aa66b94a027a6362907f0027d15a0f7e.tar.bz2
sci-e04cfb52aa66b94a027a6362907f0027d15a0f7e.zip
moved to use flag qt4, added cuda eclass
Diffstat (limited to 'sci-libs/libgeodecomp/libgeodecomp-9999.ebuild')
-rw-r--r--sci-libs/libgeodecomp/libgeodecomp-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild b/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild
index ae22a6604..22a4d8963 100644
--- a/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild
+++ b/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild
@@ -16,14 +16,14 @@ else
S="${WORKDIR}/${P}"
fi
-inherit cmake-utils ${_SCM}
+inherit cmake-utils cuda ${_SCM}
DESCRIPTION="An auto-parallelizing library to speed up computer simulations"
HOMEPAGE="http://www.libgeodecomp.org"
SLOT="0"
LICENSE="Boost-1.0"
-IUSE="cuda doc hpx mpi opencl opencv qt scotch threads visit"
+IUSE="cuda doc hpx mpi opencl opencv qt4 scotch threads visit"
RDEPEND="
>=dev-libs/boost-1.48
@@ -32,7 +32,7 @@ RDEPEND="
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
opencv? ( media-libs/opencv )
- qt? ( dev-qt/qtgui )
+ qt4? ( dev-qt/qtgui )
scotch? ( sci-libs/scotch )
visit? ( sci-visualization/visit )"
DEPEND="${RDEPEND}
@@ -47,7 +47,7 @@ src_configure() {
$(cmake-utils_use_with mpi MPI)
$(cmake-utils_use_with opencl OPENCL)
$(cmake-utils_use_with opencv OPENCV)
- $(cmake-utils_use_with qt QT)
+ $(cmake-utils_use_with qt4 QT)
$(cmake-utils_use_with scotch SCOTCH)
$(cmake-utils_use_with threads THREADS)
$(cmake-utils_use_with visit VISIT)