aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-01-22 16:17:58 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-01-22 16:17:58 +0100
commit458e1564c2fa03fefffd8a8f9dc8975d95f26c3f (patch)
treec52b8e0a3fa2e3fca0041aafe8023544ebc251bc /sci-libs/libmaus2/libmaus2-9999.ebuild
parentsci-libs/io_lib: add libdeflate to USE flags and require it (diff)
downloadsci-458e1564c2fa03fefffd8a8f9dc8975d95f26c3f.tar.gz
sci-458e1564c2fa03fefffd8a8f9dc8975d95f26c3f.tar.bz2
sci-458e1564c2fa03fefffd8a8f9dc8975d95f26c3f.zip
sci-libs/libmaus2: upstream moved from github to gitlab
https://github.com/gt1/libmaus2/issues/28#issuecomment-456336598 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Diffstat (limited to 'sci-libs/libmaus2/libmaus2-9999.ebuild')
-rw-r--r--sci-libs/libmaus2/libmaus2-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-libs/libmaus2/libmaus2-9999.ebuild b/sci-libs/libmaus2/libmaus2-9999.ebuild
index 01aa74a92..c371d5432 100644
--- a/sci-libs/libmaus2/libmaus2-9999.ebuild
+++ b/sci-libs/libmaus2/libmaus2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ inherit autotools git-r3
DESCRIPTION="Library for biobambam2"
HOMEPAGE="https://github.com/gt1/libmaus"
-EGIT_REPO_URI="https://github.com/gt1/libmaus2.git"
+EGIT_REPO_URI="https://gitlab.com/german.tischler/libmaus2"
LICENSE="BSD-2 GPL-2 GPL-3 MIT ZLIB" # BUG: incomplete list of licenses, see AUTHORS
SLOT="0"
@@ -16,9 +16,8 @@ IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2"
DEPEND="
!sci-libs/libmaus
- sci-libs/io_lib
+ >=sci-libs/io_lib-1.14.11
app-arch/snappy
- sci-biology/seqan
sci-libs/fftw
sci-libs/hdf5
net-libs/gnutls
@@ -35,12 +34,12 @@ src_configure(){
local CONFIG_OPTS
use cpu_flags_x86_ssse3 && CONFIG_OPTS+=( --enable-ssse3 )
( use cpu_flags_x86_sse4_1 || use cpu_flags_x86_sse4_2 ) && CONFIG_OPTS+=( --enable-sse4 )
- econf --with-snappy --with-seqan --with-io_lib $CONFIG_OPTS \
+ econf --with-snappy --with-io_lib $CONFIG_OPTS \
--with-lzma --with-gnutls --with-nettle --with-hdf5 --with-gmp --with-fftw
}
pkg_postinst(){
- einfo "The io_lib, snappy and seqan dependencies are not strictly needed"
+ einfo "The io_lib, snappy dependencies are not strictly needed"
einfo "but were forced for optimal libmaus2 performance."
einfo "igzip is only used if gzip level is set to 11."
}