aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-03 10:46:35 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-03 10:48:04 +0100
commite8dd1dbc67151f09574a355fafe3fd0cca451797 (patch)
treefc49e67d9e2c8521eba70a33f7faa6990678d720 /sci-libs/matc/matc-6.0_p4651.ebuild
parentsci-libs/elmer-hutiter: Fix version; force execution of all phases; Fix LICENSE (diff)
downloadsci-e8dd1dbc67151f09574a355fafe3fd0cca451797.tar.gz
sci-e8dd1dbc67151f09574a355fafe3fd0cca451797.tar.bz2
sci-e8dd1dbc67151f09574a355fafe3fd0cca451797.zip
sci-libs/matc: Fix version; force execution of all phases; Fix LICENSE
Package-Manager: portage-2.2.7 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/matc/matc-6.0_p4651.ebuild')
-rw-r--r--sci-libs/matc/matc-6.0_p4651.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/matc/matc-6.0_p4651.ebuild b/sci-libs/matc/matc-6.0_p4651.ebuild
new file mode 100644
index 000000000..429713797
--- /dev/null
+++ b/sci-libs/matc/matc-6.0_p4651.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Finite element programs, libraries, and visualization tools - math C library"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+SRC_URI="
+ http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV%_p*}/${MY_PN}/?view=tar&pathrev=4651 -> ${P}.tar.gz
+ doc? ( http://www.nic.funet.fi/pub/sci/physics/elmer/doc/MATCManual.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug static-libs"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-shared.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_with debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && DOCS=( "${DISTDIR}"/MATCManual.pdf )
+ autotools-utils_src_install
+}