aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-16 15:21:30 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-06-16 15:21:30 +0000
commit35328e9ce2293254038894a6b1b4e5427440bc9e (patch)
tree468a2b1840454b64e02eb580c7531a0517686c4e /sci-libs/matio/files
parentadded USE flags for texmacs (diff)
downloadsci-35328e9ce2293254038894a6b1b4e5427440bc9e.tar.gz
sci-35328e9ce2293254038894a6b1b4e5427440bc9e.tar.bz2
sci-35328e9ce2293254038894a6b1b4e5427440bc9e.zip
added matio-1.1.4, removed matio-1.0 (this last ebuild was unsatisfactory)
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@248 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/matio/files')
-rw-r--r--sci-libs/matio/files/Makefile.in.patch5
-rw-r--r--sci-libs/matio/files/digest-matio-1.1.4 (renamed from sci-libs/matio/files/digest-matio-1.0)0
-rw-r--r--sci-libs/matio/files/matio-1.1.4.patch73
3 files changed, 73 insertions, 5 deletions
diff --git a/sci-libs/matio/files/Makefile.in.patch b/sci-libs/matio/files/Makefile.in.patch
deleted file mode 100644
index eb80b7baa..000000000
--- a/sci-libs/matio/files/Makefile.in.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- doxygen/Makefile.in.orig 2006-03-11 03:37:32.000000000 +0100
-+++ doxygen/Makefile.in 2006-06-14 00:01:41.000000000 +0200
-@@ -182 +182 @@
--docdir = $(prefix)/doc
-+docdir = $(prefix)/share/doc/matio-1.0
diff --git a/sci-libs/matio/files/digest-matio-1.0 b/sci-libs/matio/files/digest-matio-1.1.4
index 2a3464d06..2a3464d06 100644
--- a/sci-libs/matio/files/digest-matio-1.0
+++ b/sci-libs/matio/files/digest-matio-1.1.4
diff --git a/sci-libs/matio/files/matio-1.1.4.patch b/sci-libs/matio/files/matio-1.1.4.patch
new file mode 100644
index 000000000..965033121
--- /dev/null
+++ b/sci-libs/matio/files/matio-1.1.4.patch
@@ -0,0 +1,73 @@
+diff -U2 -r matio.orig/Makefile.am matio/Makefile.am
+--- matio.orig/Makefile.am 2006-01-11 15:34:34.000000000 +0100
++++ matio/Makefile.am 2006-06-16 21:16:52.000000000 +0200
+@@ -8,7 +8,5 @@
+ ACLOCAL_AMFLAGS = -Iconfig
+
+-
+ EXTRA_DIST = matio.pc.in
+-data_DATA = share/test_file.mat share/test_file_v6.mat
+
+ pkgconfigdir = $(libdir)/pkgconfig
+@@ -21,5 +19,5 @@
+ endif
+
+-SUBDIRS = src test $(DOCS)
++SUBDIRS = src $(DOCS)
+
+ dosubst = sed -e 's,[@]PACKAGE[@],$(PACKAGE),g' \
+@@ -27,7 +25,4 @@
+ -e 's,\/,\\,g'
+
+-doc:
+-
+-
+ print:
+ subdirs='$(SUBDIRS)'; \
+diff -U2 -r matio.orig/doxygen/Makefile.am matio/doxygen/Makefile.am
+--- matio.orig/doxygen/Makefile.am 2006-01-11 15:34:29.000000000 +0100
++++ matio/doxygen/Makefile.am 2006-06-16 21:07:05.000000000 +0200
+@@ -8,5 +8,5 @@
+ VPATH = @srcdir@
+
+-docdir = $(prefix)/doc
++docdir = $(prefix)/share/doc/matio-$(PV)
+ doc_DATA = $(top_builddir)/doxygen/latex/libmatio.pdf
+
+diff -U2 -r matio.orig/src/Makefile.am matio/src/Makefile.am
+--- matio.orig/src/Makefile.am 2006-03-11 03:36:40.000000000 +0100
++++ matio/src/Makefile.am 2006-06-16 21:16:47.000000000 +0200
+@@ -9,8 +9,4 @@
+ AM_LDFLAGS =
+
+-if HAVE_ZLIB
+- ZLIB_SRC = inflate.c
+-endif
+-
+ include_HEADERS = matio.h matioConfig.h
+ lib_LTLIBRARIES = libmatio.la
+@@ -29,7 +25,4 @@
+ -e 's,\/,\\,g'
+
+-doc:
+-
+-
+ print:
+ @list='$(libmatio_a_SOURCES)'; \
+diff -U2 -r matio.orig/test/Makefile.am matio/test/Makefile.am
+--- matio.orig/test/Makefile.am 2006-02-09 20:48:24.000000000 +0100
++++ matio/test/Makefile.am 2006-06-16 21:36:44.000000000 +0200
+@@ -7,5 +7,5 @@
+ TEST_LFLAGS = $(all_libraries) -L$(top_builddir)/src
+
+-bin_PROGRAMS = test_mat test_snprintf
++noinst_PROGRAMS = test_mat test_snprintf
+
+ test_mat_SOURCES = test_mat.c
+@@ -18,5 +18,5 @@
+
+ if ENABLE_FORTRAN
+-bin_PROGRAMS += test_matf
++noinst_PROGRAMS += test_matf
+
+ test_matf_SOURCES = test_matf.f90