aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-10-05 16:48:45 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-10-05 16:48:45 +0000
commit6a6d2066913b59aaa0a494713a826c32ae3377ba (patch)
treeddebda5fee0b19498859547e9755ea5b25dc2d16 /sci-libs/matio/matio-1.3.1.ebuild
parentwxmaxima/Manifest fixed (diff)
downloadsci-6a6d2066913b59aaa0a494713a826c32ae3377ba.tar.gz
sci-6a6d2066913b59aaa0a494713a826c32ae3377ba.tar.bz2
sci-6a6d2066913b59aaa0a494713a826c32ae3377ba.zip
matio: minor cleanup
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@341 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/matio/matio-1.3.1.ebuild')
-rw-r--r--sci-libs/matio/matio-1.3.1.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/sci-libs/matio/matio-1.3.1.ebuild b/sci-libs/matio/matio-1.3.1.ebuild
index baf1f2d49..1bc753a1f 100644
--- a/sci-libs/matio/matio-1.3.1.ebuild
+++ b/sci-libs/matio/matio-1.3.1.ebuild
@@ -2,39 +2,37 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+inherit eutils fortran
DESCRIPTION="Library for reading and writing matlab .mat files"
HOMEPAGE="http://sourceforge.net/projects/matio/"
SLOT="0"
-LICENSE="LGPL"
+LICENSE="LGPL-2"
KEYWORDS="~x86"
IUSE="doc fortran"
-RESTRICT="nomirror"
SRC_URI="mirror://sourceforge/matio/${P}.tar.gz"
-DEPEND="doc? ( app-doc/doxygen virtual/tetex )
- fortran? ( >=gcc-4.1 )"
+DEPEND="doc? ( app-doc/doxygen virtual/tetex )"
+FORTRAN="gfortran"
+
+#### Remove the following line when moving this ebuild to the main tree!
+RESTRICT="nomirror"
pkg_setup() {
- if use fortran ; then
- if ! built_with_use gcc fortran ; then
- einfo "Please re-emerge gcc with the USE flag fortran and try again"
- die
- fi
- fi
+ use fortran && fortran_pkg_setup
}
src_compile() {
addwrite /var/cache/fonts
addwrite /usr/share/texmf
- aclocal -I config
- automake
- econf --enable-shared --disable-test $(use_enable fortran ) $(use_enable doc docs ) \
+ econf --enable-shared \
+ --disable-test \
+ $(use_enable fortran ) \
+ $(use_enable doc docs ) \
|| die "econf failed"
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog
}