aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
commit76ffb781ed7a917f23b67454e9f950e5e3b83527 (patch)
tree94fa8e1ddc7cb9ef80b78ea7896a5845f074f95b /sci-libs/matio/matio-1.3.1.ebuild
parentmove stuff to root (diff)
downloadsci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.gz
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.bz2
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.zip
moved overlay to new directory
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@979 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/matio/matio-1.3.1.ebuild')
-rw-r--r--sci-libs/matio/matio-1.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/matio/matio-1.3.1.ebuild b/sci-libs/matio/matio-1.3.1.ebuild
new file mode 100644
index 000000000..a5cc1da74
--- /dev/null
+++ b/sci-libs/matio/matio-1.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils fortran
+
+DESCRIPTION="Library for reading and writing matlab .mat files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc fortran"
+SRC_URI="mirror://sourceforge/matio/${P}.tar.gz"
+DEPEND="doc? ( app-doc/doxygen virtual/tetex )"
+FORTRAN="gfortran"
+
+#### Remove the following line when moving this ebuild to the main tree!
+RESTRICT="nomirror"
+
+pkg_setup() {
+ use fortran && fortran_pkg_setup
+}
+
+src_compile() {
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf
+ econf --enable-shared \
+ --disable-test \
+ $(use_enable fortran ) \
+ $(use_enable doc docs ) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog
+}