aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-09-20 20:09:54 +0000
committergrozin <grozin@32389bae-6d03-0410-99cf-db05cde120eb>2006-09-20 20:09:54 +0000
commitbadb5552bc3003e15378356a2fdc55f8a3bf76e4 (patch)
tree68618756d6640a40938ab17dcc56cff918af0f97 /sci-libs/matio/matio-1.3.1.ebuild
parentqcl ebuild now honours the user's $CXXFLAGS (diff)
downloadsci-badb5552bc3003e15378356a2fdc55f8a3bf76e4.tar.gz
sci-badb5552bc3003e15378356a2fdc55f8a3bf76e4.tar.bz2
sci-badb5552bc3003e15378356a2fdc55f8a3bf76e4.zip
matio-1.3.1: version bump
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@317 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'sci-libs/matio/matio-1.3.1.ebuild')
-rw-r--r--sci-libs/matio/matio-1.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/matio/matio-1.3.1.ebuild b/sci-libs/matio/matio-1.3.1.ebuild
new file mode 100644
index 000000000..baf1f2d49
--- /dev/null
+++ b/sci-libs/matio/matio-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Library for reading and writing matlab .mat files"
+HOMEPAGE="http://sourceforge.net/projects/matio/"
+SLOT="0"
+LICENSE="LGPL"
+KEYWORDS="~x86"
+IUSE="doc fortran"
+RESTRICT="nomirror"
+SRC_URI="mirror://sourceforge/matio/${P}.tar.gz"
+DEPEND="doc? ( app-doc/doxygen virtual/tetex )
+ fortran? ( >=gcc-4.1 )"
+
+pkg_setup() {
+ if use fortran ; then
+ if ! built_with_use gcc fortran ; then
+ einfo "Please re-emerge gcc with the USE flag fortran and try again"
+ die
+ fi
+ fi
+}
+
+src_compile() {
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf
+ aclocal -I config
+ automake
+ econf --enable-shared --disable-test $(use_enable fortran ) $(use_enable doc docs ) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc README ChangeLog
+}