aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <debdepba@dasganma.tk>2015-12-31 17:01:57 +0100
committerChris Kerr <debdepba@dasganma.tk>2016-01-10 14:19:34 +0100
commit88a50b5ea0d003ac41aa047d45994af1d00a38b7 (patch)
treee551deacb68298b199fa9c099216834d54d1863c /sci-libs/nexus/nexus-4.4.1.ebuild
parentsci-libs/arrayfire: Version bump to 3.2.2 (diff)
downloadsci-88a50b5ea0d003ac41aa047d45994af1d00a38b7.tar.gz
sci-88a50b5ea0d003ac41aa047d45994af1d00a38b7.tar.bz2
sci-88a50b5ea0d003ac41aa047d45994af1d00a38b7.zip
Update NeXus ebuild to version 4.4.1
Versions from 4.4 are built with CMake Python support is now in a separate project, called Nexpy
Diffstat (limited to 'sci-libs/nexus/nexus-4.4.1.ebuild')
-rw-r--r--sci-libs/nexus/nexus-4.4.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/nexus/nexus-4.4.1.ebuild b/sci-libs/nexus/nexus-4.4.1.ebuild
new file mode 100644
index 000000000..53b5ba159
--- /dev/null
+++ b/sci-libs/nexus/nexus-4.4.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils fortran-2 java-pkg-opt-2
+
+DESCRIPTION="Data format for neutron and x-ray scattering data"
+HOMEPAGE="http://nexusformat.org/"
+SRC_URI="https://github.com/nexusformat/code/archive/v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc cxx fortran -hdf4 +hdf5 java utils xml"
+
+REQUIRED_USE=" || ( hdf4 hdf5 xml ) "
+
+RDEPEND="
+ xml? ( dev-libs/mxml )
+ hdf4? ( sci-libs/hdf )
+ hdf5? ( sci-libs/hdf5[zlib] )
+ utils? ( sys-libs/readline:0 sys-libs/libtermcap-compat dev-libs/libxml2 )
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen dev-tex/xcolor )
+"
+
+pkg_setup() {
+ # Handling of dependencies between Fortran module files doesn't play well with parallel make
+ use fortran && export MAKEOPTS="${MAKEOPTS} -j1 "
+ use fortran && fortran-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
+}
+
+src_configure() {
+ # Linking between Fortran libraries gives a relocation error, using workaround suggested at:
+ # http://www.gentoo.org/proj/en/base/amd64/howtos/?part=1&chap=3
+ use fortran && append-fflags -fPIC
+
+ cmake-utils_src_configure \
+ $(cmake-utils_use_enable hdf4) \
+ $(cmake-utils_use_enable hdf5) \
+ $(cmake-utils_use_enable xml MXML) \
+ $(cmake-utils_use_enable cxx) \
+ $(cmake-utils_use_enable fortran FORTRAN90) \
+ $(cmake-utils_use_enable fortran FORTRAN77) \
+ $(cmake-utils_use_enable java) \
+ $(cmake-utils_use_enable utils APPS) \
+ $(cmake-utils_use_enable utils CONTRIB)
+}