aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobbert Harms <robbert@xkls.nl>2015-08-30 09:31:32 +0200
committerRobbert Harms <robbert@xkls.nl>2015-08-30 09:31:32 +0200
commit8b3816cb8ff03dc927608cc5575e4c079eaa3728 (patch)
treeebbec909e801280289d5c8e41e609ad4801e9f3c /sci-libs/nibabel/nibabel-2.0.1.ebuild
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-8b3816cb8ff03dc927608cc5575e4c079eaa3728.tar.gz
sci-8b3816cb8ff03dc927608cc5575e4c079eaa3728.tar.bz2
sci-8b3816cb8ff03dc927608cc5575e4c079eaa3728.zip
Version bump, adds nibabel-2.0.1. Also, version-2.0.1 now has python3_4 as python version dependency.
Diffstat (limited to 'sci-libs/nibabel/nibabel-2.0.1.ebuild')
-rw-r--r--sci-libs/nibabel/nibabel-2.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/nibabel/nibabel-2.0.1.ebuild b/sci-libs/nibabel/nibabel-2.0.1.ebuild
new file mode 100644
index 000000000..6d2f25d4a
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-2.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+SRC_URI="https://github.com/nipy/nibabel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dicom doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ )
+ "
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ distutils-r1_install_for_testing
+ cd "${BUILD_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. nosetests || die
+}