aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <h.chr@mail.ru>2015-11-11 23:38:40 +0100
committerHorea Christian <h.chr@mail.ru>2015-11-11 23:38:40 +0100
commit11abed023da7f2d1fb261332dacf829a4c1a666b (patch)
treef25717f03e2e58b701cb3a051e1c081ac01e627e /sci-libs/nipy/nipy-0.4.0.ebuild
parentdev-python/qtconsole: Depend on threading support in python (diff)
downloadsci-11abed023da7f2d1fb261332dacf829a4c1a666b.tar.gz
sci-11abed023da7f2d1fb261332dacf829a4c1a666b.tar.bz2
sci-11abed023da7f2d1fb261332dacf829a4c1a666b.zip
sci-libs/nipy: version bump
Package-Manager: portage-2.2.23
Diffstat (limited to 'sci-libs/nipy/nipy-0.4.0.ebuild')
-rw-r--r--sci-libs/nipy/nipy-0.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/nipy/nipy-0.4.0.ebuild b/sci-libs/nipy/nipy-0.4.0.ebuild
new file mode 100644
index 000000000..e9d3f1362
--- /dev/null
+++ b/sci-libs/nipy/nipy-0.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib flag-o-matic
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+}