aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-08-10 15:51:08 +0200
committerBenda Xu <heroxbd@gentoo.org>2017-08-25 13:03:31 +0900
commit18271c7c67a0bf33cacbee05217c8abd536e9f15 (patch)
tree2292609f8dbce080e4c94cdcfd1714c8d388fcf6 /sci-libs/nipy
parentsci-libs/nibabel: fixed indentation (diff)
downloadsci-18271c7c67a0bf33cacbee05217c8abd536e9f15.tar.gz
sci-18271c7c67a0bf33cacbee05217c8abd536e9f15.tar.bz2
sci-18271c7c67a0bf33cacbee05217c8abd536e9f15.zip
sci-libs/nipy: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sci-libs/nipy')
-rw-r--r--sci-libs/nipy/Manifest1
-rw-r--r--sci-libs/nipy/metadata.xml28
-rw-r--r--sci-libs/nipy/nipy-0.4.1.ebuild40
3 files changed, 55 insertions, 14 deletions
diff --git a/sci-libs/nipy/Manifest b/sci-libs/nipy/Manifest
index a38b3d741..3d571b71e 100644
--- a/sci-libs/nipy/Manifest
+++ b/sci-libs/nipy/Manifest
@@ -1,2 +1,3 @@
DIST nipy-0.3.0.tar.gz 2143887 SHA256 74fef65c832795a35e1757d8bd852177fae190517a964afcb0812cfc1107d155 SHA512 3eaab4628bfa1706c99d516242387e1a27330bbf03b5b79da80d9a5e697b4e779f8f059e6f7bcc4253c5ad7af1bf6c600bcc5bd87db95d2e38f445d1f4416106 WHIRLPOOL 8a27c42abd8c7ae5ce66b8cfb0686b79e3208950107fcc5090d88fa2c23bf15d4ce4ae5b598f6f51c6e70122c40a343b9b7b2950ef09aefaeb22e24efd854af0
DIST nipy-0.4.0.tar.gz 2282476 SHA256 d906e19bb845ab1cc3f7ea07959d4ce53a780a135a20f095a2ae4b47a2b0cbc2 SHA512 b565b421490a015986e6ab55c22e14acffb4c782b18a248b4e0e2e84d332ed83dd92217ea56067a09405613a733474acd67c8bcc06d478394abf03904861fb94 WHIRLPOOL 9e9b9748322ff1ca2e969cf5de19eccb2e057d1234a92e42ec8e9713691fff33c595d2ebeb51788f6d034d5588c68588199331f63c81cbcae02c159d5d31fea7
+DIST nipy-0.4.1.tar.gz 2386728 SHA256 249a6cc41b2405ebb7eb85b8aef052949adda34b11559f4c8ee2855e73adcf4d SHA512 385621e45e8301bbb71765bb7e8e1eca31644c5bd713672c673e8074ab666a28001152a66da992c7fe51f149097c526458956df4323e8c65ca5e1fdf6468090a WHIRLPOOL c0b0242a429ffc6fcae5b8a2a6f76dd647f7585f3cbefcba273fb45d12ce851b37992e3c77e05d3743f65d1ae1735ea1767291bc2cf8ff2666e89a5d13f35b87
diff --git a/sci-libs/nipy/metadata.xml b/sci-libs/nipy/metadata.xml
index 940d59042..16398ad90 100644
--- a/sci-libs/nipy/metadata.xml
+++ b/sci-libs/nipy/metadata.xml
@@ -1,18 +1,18 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>horea.christ@gmail.com</email>
- <name>Horea Christian</name>
- </maintainer>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- NIPY is a python project for analysis of structural and functional neuroimaging data.
- </longdescription>
- <upstream>
- <remote-id type="pypi">nipy</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ NIPY is a python project for analysis of structural and functional neuroimaging data.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">nipy</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-libs/nipy/nipy-0.4.1.ebuild b/sci-libs/nipy/nipy-0.4.1.ebuild
new file mode 100644
index 000000000..a886c1c42
--- /dev/null
+++ b/sci-libs/nipy/nipy-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 eutils multilib flag-o-matic
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/prov[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ "
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+}