aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-01-22 09:39:15 -0500
committerHorea Christian <chr@chymera.eu>2024-01-22 09:39:15 -0500
commit1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c (patch)
tree0f71c6fb37e8b05c76e525f896aff03e23c98eaa /sci-libs/nipype/nipype-1.5.0.ebuild
parentmedia-gfx/brlcad: updated doxygen dependency category (diff)
downloadsci-1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c.tar.gz
sci-1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c.tar.bz2
sci-1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c.zip
sci-libs/nipype: add 1.8.6, drop 1.5.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/nipype/nipype-1.5.0.ebuild')
-rw-r--r--sci-libs/nipype/nipype-1.5.0.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/sci-libs/nipype/nipype-1.5.0.ebuild b/sci-libs/nipype/nipype-1.5.0.ebuild
deleted file mode 100644
index 750c3ba05..000000000
--- a/sci-libs/nipype/nipype-1.5.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
-HOMEPAGE="https://nipype.readthedocs.io/"
-SRC_URI="https://github.com/nipy/nipype/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/prov[${PYTHON_USEDEP}]
- sci-libs/nibabel[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
-"
-# Dependency disabled as upstream test configuration which requires it fails
-#dev-python/pytest-xdist[${PYTHON_USEDEP}]
-
-RDEPEND="
- >=dev-python/click-6.6[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pydot[${PYTHON_USEDEP}]
- dev-python/pydotplus[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/rdflib-5.0.0[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/traits[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${P}"-version_check.patch
- "${FILESDIR}/${P}"-collections.patch
-)
-
-src_prepare() {
- # Remove etelemetry
- sed -i '/"etelemetry/d' nipype/info.py requirements.txt || die
-
- # Mark failing tests
- sed -i \
- -e "/def test_no_et(tmp_path):/i@pytest.mark.skip('Known to fail by upstream: https://github.com/nipy/nipype/issues/3196#issuecomment-606003186')" \
- nipype/tests/test_nipype.py || die
- sed -i \
- -e "/def test_fslversion():/i@pytest.mark.skip('Known to fail by upstream: https://github.com/nipy/nipype/issues/3196#issuecomment-605997462')" \
- nipype/interfaces/fsl/tests/test_base.py || die
- default
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doenvd "${FILESDIR}/98nipype"
-}
-
-EPYTEST_DESELECT=(
- nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_compcor
- nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_compcor_variance_threshold_and_metadata
- nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_tcompcor
- nipype/interfaces/tests/test_io.py::test_s3datagrabber_communication
- nipype/utils/tests/test_cmd.py::TestNipypeCMD::test_main_returns_0_on_help
-)
-
-python_test() {
- # Setting environment variable to disable etelemetry version check:
- # https://github.com/nipy/nipype/issues/3196#issuecomment-605980044
- NIPYPE_NO_ET=1 epytest
- # Upstream test configuration fails
- #-c nipype/pytest.ini\
- #--doctest-modules nipype\
- #--cov nipype\
- #--cov-config .coveragerc\
- #--cov-report xml:cov.xml\
-}
-
-pkg_postinst() {
- echo
- einfo "Please run the following commands if you"
- einfo "intend to use nipype from an existing shell:"
- einfo "source /etc/profile"
- echo
-}