aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Arteaga <andyspiros@gmail.com>2012-03-23 21:21:02 +0100
committerAndrea Arteaga <andyspiros@gmail.com>2012-03-23 21:21:02 +0100
commit8df1a9ed5ce544bb360a6b29d9afe40cf2af21cb (patch)
treedec80ca0d5c282a10c394ad0ebc0fc2525804744 /sci-libs/openblas/files
parentusing PATCHES variable instead of epatch (diff)
downloadsci-8df1a9ed5ce544bb360a6b29d9afe40cf2af21cb.tar.gz
sci-8df1a9ed5ce544bb360a6b29d9afe40cf2af21cb.tar.bz2
sci-8df1a9ed5ce544bb360a6b29d9afe40cf2af21cb.zip
[sci-libs/openblas] First stable version.
Diffstat (limited to 'sci-libs/openblas/files')
-rw-r--r--sci-libs/openblas/files/openblas-sharedlibs-0.1.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/openblas/files/openblas-sharedlibs-0.1.patch b/sci-libs/openblas/files/openblas-sharedlibs-0.1.patch
new file mode 100644
index 000000000..c2e658072
--- /dev/null
+++ b/sci-libs/openblas/files/openblas-sharedlibs-0.1.patch
@@ -0,0 +1,45 @@
+--- exports/Makefile.orig 2010-11-12 05:30:06.000000000 +0000
++++ exports/Makefile 2010-11-12 06:33:41.000000000 +0000
+@@ -97,10 +97,10 @@
+ so : ../$(LIBSONAME)
+
+ ../$(LIBSONAME) : ../$(LIBNAME) linux.def linktest.c
+- $(CC) $(CFLAGS) -shared -o ../$(LIBSONAME) \
+- -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive \
+- -Wl,--retain-symbols-file=linux.def -Wl,-soname,$(LIBPREFIX).so.$(MAJOR_VERSION) $(EXTRALIB)
+- $(CC) $(CFLAGS) -w -o linktest linktest.c ../$(LIBSONAME) $(FEXTRALIB) && echo OK.
++ $(CC) $(LDFLAGS) -shared \
++ -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive -Wl,--soname=$(LIBSONAME) \
++ -Wl,--retain-symbols-file=linux.def $(EXTRALIB) -o ../$(LIBSONAME)
++ $(CC) $(CFLAGS) -w linktest.c ../$(LIBSONAME) $(FEXTRALIB) -o linktest && echo OK.
+ rm -f linktest
+
+ endif
+@@ -110,10 +110,10 @@
+ so : ../$(LIBSONAME)
+
+ ../$(LIBSONAME) : ../$(LIBNAME) linux.def linktest.c
+- $(CC) $(CFLAGS) -shared -o ../$(LIBSONAME) \
+- -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive \
+- -Wl,--retain-symbols-file=linux.def $(EXTRALIB)
+- $(CC) $(CFLAGS) -w -o linktest linktest.c ../$(LIBSONAME) $(FEXTRALIB) && echo OK.
++ $(CC) $(LDFLAGS) -shared \
++ -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive -Wl,--soname=$(LIBSONAME) \
++ -Wl,--retain-symbols-file=linux.def $(EXTRALIB) -o ../$(LIBSONAME)
++ $(CC) $(CFLAGS) -w linktest.c ../$(LIBSONAME) $(FEXTRALIB) -o linktest && echo OK.
+ rm -f linktest
+
+ endif
+@@ -129,9 +129,9 @@
+ ifeq ($(OSNAME), SunOS)
+
+ so : ../$(LIBSONAME)
+- $(CC) $(CFLAGS) -shared -o ../$(LIBSONAME) \
+- -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive $(EXTRALIB)
+- $(CC) $(CFLAGS) -w -o linktest linktest.c ../$(LIBSONAME) $(FEXTRALIB) && echo OK.
++ $(CC) $(LDFLAGS) -shared -Wl,--soname=$(LIBSONAME) \
++ -Wl,--whole-archive ../$(LIBNAME) -Wl,--no-whole-archive $(EXTRALIB) -o ../$(LIBSONAME)
++ $(CC) $(CFLAGS) -w linktest.c ../$(LIBSONAME) $(FEXTRALIB) -o linktest && echo OK.
+ rm -f linktest
+
+ endif