aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-05-17 23:52:29 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-05-17 23:52:29 +0100
commit0e65bbce29e8da935fe24f0f996bf740a9e30929 (patch)
tree2d9cfe4aed0db05c3b06a092b7e05a7443e66a4c /sci-libs/optpp
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
downloadsci-0e65bbce29e8da935fe24f0f996bf740a9e30929.tar.gz
sci-0e65bbce29e8da935fe24f0f996bf740a9e30929.tar.bz2
sci-0e65bbce29e8da935fe24f0f996bf740a9e30929.zip
sci-libs/optpp: Initial import
(Portage version: 2.1.10.60/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-libs/optpp')
-rw-r--r--sci-libs/optpp/ChangeLog10
-rw-r--r--sci-libs/optpp/Manifest1
-rw-r--r--sci-libs/optpp/metadata.xml19
-rw-r--r--sci-libs/optpp/optpp-2.4.ebuild34
4 files changed, 64 insertions, 0 deletions
diff --git a/sci-libs/optpp/ChangeLog b/sci-libs/optpp/ChangeLog
new file mode 100644
index 000000000..62a8977ad
--- /dev/null
+++ b/sci-libs/optpp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/optpp
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*optpp-2.4 (17 May 2012)
+
+ 17 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +optpp-2.4.ebuild:
+ sci-libs/optpp: Initial import
+
diff --git a/sci-libs/optpp/Manifest b/sci-libs/optpp/Manifest
new file mode 100644
index 000000000..2c079ac29
--- /dev/null
+++ b/sci-libs/optpp/Manifest
@@ -0,0 +1 @@
+DIST optpp-2.4.tar.gz 2233938 SHA256 b452cdf8aa770088e26b49e07b5cf13ae5972832c032abcad07a56baa2a588ef SHA512 f29ff51531e34e442d5c5479f278d0a3efa5a0ef7d893dc85e037255b68021ac2382c1065c0133e010c98b8cbadd783b2e17d861fe9f549e22fd85a40ba05a8f WHIRLPOOL c08083a55735200068d0b775950d2d70de7404de01f7c960e7109aefdef77e6c458b409bbe53172ca9e404293cf53a891e0798b4dbbad7b2835b748e32ed5e1d
diff --git a/sci-libs/optpp/metadata.xml b/sci-libs/optpp/metadata.xml
new file mode 100644
index 000000000..db2b13b85
--- /dev/null
+++ b/sci-libs/optpp/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+<longdescription lang="en">
+ OPT++ is a library of nonlinear optimization algorithms written in
+ C++. The motivation for this package is to build an environment for
+ the rapid prototyping and development of new optimization
+ algorithms. In particular, the focus is on robust and efficient
+ algorithms for problems in which the function and constraint
+ evaluations require the execution of an expensive computer
+ simulation. Currently, OPT++ includes the classic Newton methods, a
+ nonlinear interior-point method, parallel direct search, generating
+ set search, a trust region - parallel direct search hybrid, and a
+ wrapper to NPSOL. Between these methods, a wide range of problems
+ can be solved, e.g. with or without constraints, with or without
+ analytic gradients, simulation based, etc.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/optpp/optpp-2.4.ebuild b/sci-libs/optpp/optpp-2.4.ebuild
new file mode 100644
index 000000000..260cfd242
--- /dev/null
+++ b/sci-libs/optpp/optpp-2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit python autotools-utils
+
+DESCRIPTION="C++ library for non-linear optimization"
+HOMEPAGE="https://software.sandia.gov/opt++/"
+SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc mpi static-libs"
+
+RDEPEND="virtual/blas
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myeconfargs+=(
+ --with-blas="$(pkg-config --libs blas)"
+ $(use_enable mpi)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r docs/*
+}