aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 10:47:53 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-22 10:47:53 +0100
commit7a99cdd3182a10f764d9ef25fdbad65672942908 (patch)
treed8e96454e2ac2a4766f29d49fc141ace0c4944eb /sci-libs/optpp
parentsci-libs/wannier90: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead ... (diff)
downloadsci-7a99cdd3182a10f764d9ef25fdbad65672942908.tar.gz
sci-7a99cdd3182a10f764d9ef25fdbad65672942908.tar.bz2
sci-7a99cdd3182a10f764d9ef25fdbad65672942908.zip
sci-libs/optpp: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; bump to EAPI=5; move to new python eclasses
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'sci-libs/optpp')
-rw-r--r--sci-libs/optpp/ChangeLog6
-rw-r--r--sci-libs/optpp/metadata.xml4
-rw-r--r--sci-libs/optpp/optpp-2.4.ebuild13
3 files changed, 15 insertions, 8 deletions
diff --git a/sci-libs/optpp/ChangeLog b/sci-libs/optpp/ChangeLog
index 62a8977ad..5c107e97e 100644
--- a/sci-libs/optpp/ChangeLog
+++ b/sci-libs/optpp/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-libs/optpp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 Feb 2013; Justin Lecher <jlec@gentoo.org> optpp-2.4.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ bump to EAPI=5; move to new python eclasses
+
*optpp-2.4 (17 May 2012)
17 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
diff --git a/sci-libs/optpp/metadata.xml b/sci-libs/optpp/metadata.xml
index db2b13b85..644aab62a 100644
--- a/sci-libs/optpp/metadata.xml
+++ b/sci-libs/optpp/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
OPT++ is a library of nonlinear optimization algorithms written in
C++. The motivation for this package is to build an environment for
the rapid prototyping and development of new optimization
diff --git a/sci-libs/optpp/optpp-2.4.ebuild b/sci-libs/optpp/optpp-2.4.ebuild
index 260cfd242..85af83af9 100644
--- a/sci-libs/optpp/optpp-2.4.ebuild
+++ b/sci-libs/optpp/optpp-2.4.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-inherit python autotools-utils
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit autotools-utils toolchain-funcs python-single-r1
DESCRIPTION="C++ library for non-linear optimization"
HOMEPAGE="https://software.sandia.gov/opt++/"
@@ -15,14 +17,15 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc mpi static-libs"
-RDEPEND="virtual/blas
+RDEPEND="
+ virtual/blas
mpi? ( virtual/mpi )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
myeconfargs+=(
- --with-blas="$(pkg-config --libs blas)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
$(use_enable mpi)
)
autotools-utils_src_configure