aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-24 18:59:48 +0200
committerJustin Lecher <jlec@gentoo.org>2011-06-24 18:59:48 +0200
commitd8620bfa7e129e030c55a052be9388ca5c70ec65 (patch)
tree076de7f41926fdf5d42ab8c24b60a279a5211ba6 /sci-libs/pfft/pfft-1.0_alpha1.ebuild
parentShorten Summary (diff)
downloadsci-d8620bfa7e129e030c55a052be9388ca5c70ec65.tar.gz
sci-d8620bfa7e129e030c55a052be9388ca5c70ec65.tar.bz2
sci-d8620bfa7e129e030c55a052be9388ca5c70ec65.zip
Fixed Manifest and cleaned ebuild
(Portage version: 2.2.0_alpha41/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/pfft/pfft-1.0_alpha1.ebuild')
-rw-r--r--sci-libs/pfft/pfft-1.0_alpha1.ebuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/sci-libs/pfft/pfft-1.0_alpha1.ebuild b/sci-libs/pfft/pfft-1.0_alpha1.ebuild
index 072cf29aa..d44f96acf 100644
--- a/sci-libs/pfft/pfft-1.0_alpha1.ebuild
+++ b/sci-libs/pfft/pfft-1.0_alpha1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=4
inherit autotools eutils
-DESCRIPTION="parallel 3d FFT"
+DESCRIPTION="Parallel 3d FFT"
HOMEPAGE="http://www-user.tu-chemnitz.de/~mpip/software.php"
SRC_URI="http://www-user.tu-chemnitz.de/~mpip/software/${P//_}.tar.gz"
@@ -15,9 +15,9 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="static-libs"
-RDEPEND="=sci-libs/fftw-3.3*[mpi]
+RDEPEND="
+ =sci-libs/fftw-3.3*[mpi]
virtual/mpi"
-
DEPEND="${RDEPEND}"
S="${WORKDIR}/${P//_}"
@@ -28,17 +28,9 @@ src_prepare() {
cp "${FILESDIR}"/"${PF//_}"-"${i}" "${i}" || die "cp of ${i} failed"
done
- eautoreconf || die "eautoreconf failed"
+ eautoreconf
}
src_configure() {
- econf --disable-la-files "$(use_enable static-libs static)" || die "econf failed"
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
+ econf --disable-la-files "$(use_enable static-libs static)"
}