aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinis Danne <rei4dan@gmail.com>2014-01-10 00:00:17 +0200
committerReinis Danne <rei4dan@gmail.com>2014-01-10 00:00:17 +0200
commit0b2850fab6f2263a90fafb5496706f891d837aeb (patch)
tree269fd73f7411a378382e90b14b4140f2545338f1 /sci-libs/pmx
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-0b2850fab6f2263a90fafb5496706f891d837aeb.tar.gz
sci-0b2850fab6f2263a90fafb5496706f891d837aeb.tar.bz2
sci-0b2850fab6f2263a90fafb5496706f891d837aeb.zip
Add sci-libs/pmx
Diffstat (limited to 'sci-libs/pmx')
-rw-r--r--sci-libs/pmx/ChangeLog10
-rw-r--r--sci-libs/pmx/metadata.xml13
-rw-r--r--sci-libs/pmx/pmx-9999.ebuild26
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-libs/pmx/ChangeLog b/sci-libs/pmx/ChangeLog
new file mode 100644
index 000000000..0cb571fbb
--- /dev/null
+++ b/sci-libs/pmx/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/pmx
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pmx-9999 (09 Jan 2014)
+
+ 09 Jan 2014; Reinis Danne <rei4dan@gmail.com> +pmx-9999.ebuild,
+ +metadata.xml:
+ New ebuild.
+
diff --git a/sci-libs/pmx/metadata.xml b/sci-libs/pmx/metadata.xml
new file mode 100644
index 000000000..ae81f58a6
--- /dev/null
+++ b/sci-libs/pmx/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ pmx (formerly pymacs) has started as a small bunch of classes to read
+ structure files such as pdb or gro and trajectory data in gromacs xtc
+ format. Over the years it has been extended towards a versatile (bio-)
+ molecular structure manipulation package with some additional
+ functionalities, e.g. gromacs file parsers and scripts for setup and
+ analysis of free energy calculations.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-libs/pmx/pmx-9999.ebuild b/sci-libs/pmx/pmx-9999.ebuild
new file mode 100644
index 000000000..2d073e420
--- /dev/null
+++ b/sci-libs/pmx/pmx-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils distutils-r1 git-r3
+
+DESCRIPTION="Python library to read PDB, GRO or Gromacs XTC files"
+HOMEPAGE="http://code.google.com/p/pmx"
+EGIT_REPO_URI="https://code.google.com/p/${PN}.git"
+EGIT_NONSHALLOW=true
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ sci-chemistry/gromacs
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ "
+
+RDEPEND="${DEPEND}"