aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-20 10:48:22 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-20 10:48:22 +0100
commite4f65feaa95b25f541573d824e9afb03e195f7cb (patch)
tree89b0ed774e24364f2c982b5f5d1fa31cf5c152dd /sci-libs/spams-python
parentsci-libs/nipype: drop old failed REQUIRED_USE: py_targets_py3_7 (diff)
downloadsci-e4f65feaa95b25f541573d824e9afb03e195f7cb.tar.gz
sci-e4f65feaa95b25f541573d824e9afb03e195f7cb.tar.bz2
sci-e4f65feaa95b25f541573d824e9afb03e195f7cb.zip
sci-libs/spams-python: bump python targets
fails to compile without openblas Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-libs/spams-python')
-rw-r--r--sci-libs/spams-python/Manifest2
-rw-r--r--sci-libs/spams-python/spams-python-2.6.2.ebuild (renamed from sci-libs/spams-python/spams-python-2.6.ebuild)9
2 files changed, 6 insertions, 5 deletions
diff --git a/sci-libs/spams-python/Manifest b/sci-libs/spams-python/Manifest
index a86d9e583..d58c9e869 100644
--- a/sci-libs/spams-python/Manifest
+++ b/sci-libs/spams-python/Manifest
@@ -1 +1 @@
-DIST spams-python-2.6.tar.gz 1721573 BLAKE2B b172ecb06b1bd008e9c9a7cd6b8ba41468dc5797c3f7cf7f025c49c19b78911ca346578ee7e87e6b3dfcfc97eea8e5625a4162844bc183a83f1460dbae45c3a5 SHA512 e9ddd53eacaf95aca2d1dc3e84403bf30705ec5b87969480a710ec529c7a503de7526b66bf7060e958ae090d0d25ffa82593e7bc0c902516a5c04be11f853941
+DIST spams-python-2.6.2.tar.gz 315332 BLAKE2B 1aa972a65c2f69de859391b98a28972ebbd30f166ea3d44083933f746e119105d45d6ee5adff99064dc396f5522c31e5dd4055210c82e93c1217a06bf4bce2f2 SHA512 dec2ce2abe5abeb78bf470952c5f854501bf9ea21019dda1de66683f813153e78cc9b87b5376e91ac74beedb4d13854cc053e54e97bfded4177728c540812a9f
diff --git a/sci-libs/spams-python/spams-python-2.6.ebuild b/sci-libs/spams-python/spams-python-2.6.2.ebuild
index f1ad8811e..99b1e6370 100644
--- a/sci-libs/spams-python/spams-python-2.6.ebuild
+++ b/sci-libs/spams-python/spams-python-2.6.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1 toolchain-funcs
@@ -13,12 +13,13 @@ SRC_URI="https://github.com/samuelstjean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
KEYWORDS="~amd64"
DEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- virtual/blas
+ dev-python/pillow[${PYTHON_USEDEP}]
+ sci-libs/openblas
virtual/lapack
"
RDEPEND="${DEPEND}