aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-01-08 09:25:02 +0100
committerJustin Lecher <jlec@gentoo.org>2012-01-08 09:25:02 +0100
commit0fbf38a148e10ced3da581dba296da0f94882fb8 (patch)
treee8025189e1e67a899b2576d49809228a1b39af3e /sci-libs/starparse/starparse-9999.ebuild
parentVersion Bump, #373679 (diff)
downloadsci-0fbf38a148e10ced3da581dba296da0f94882fb8.tar.gz
sci-0fbf38a148e10ced3da581dba296da0f94882fb8.tar.bz2
sci-0fbf38a148e10ced3da581dba296da0f94882fb8.zip
Bumped to new upstream repo uri
(Portage version: 2.2.0_alpha84/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/starparse/starparse-9999.ebuild')
-rw-r--r--sci-libs/starparse/starparse-9999.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/sci-libs/starparse/starparse-9999.ebuild b/sci-libs/starparse/starparse-9999.ebuild
index 93fc1bada..263809b11 100644
--- a/sci-libs/starparse/starparse-9999.ebuild
+++ b/sci-libs/starparse/starparse-9999.ebuild
@@ -1,29 +1,32 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EBZR_REPO_URI="http://oregonstate.edu/~benisong/software/projects/starparse/head"
-EBZR_BOOTSTRAP="eautoreconf"
+EAPI=4
-inherit autotools bzr
+AUTOTOOLS_AUTORECONF="true"
+
+inherit autotools-utils git-2
DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
HOMEPAGE="http://burrow-owl.sourceforge.net/"
#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+EGIT_REPO_URI="git://burrow-owl.git.sourceforge.net/gitroot/burrow-owl/starparse"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="guile"
+IUSE="guile static-libs"
RDEPEND="guile? ( dev-scheme/guile )"
DEPEND="${RDEPEND}"
-src_compile() {
- econf $(use_enable guile) || die
- emake || die
-}
+AUTOTOOLS_IN_SOURCE_BUILD=1
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+src_configure() {
+ local myeconfargs=(
+ $(use_enable guile)
+ )
+ autotools-utils_src_configure
+ emake || die
}