aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-28 20:10:53 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-28 20:10:53 +0100
commitbbe8747e08b63ab3b1344af3b1eaeeb901a7f359 (patch)
tree8549085344190fd62171047e9692d80d47f20abd /sci-libs/starparse/starparse-9999.ebuild
parentsci-libs/starparse: Add missing dep on pkgconfig (diff)
downloadsci-bbe8747e08b63ab3b1344af3b1eaeeb901a7f359.tar.gz
sci-bbe8747e08b63ab3b1344af3b1eaeeb901a7f359.tar.bz2
sci-bbe8747e08b63ab3b1344af3b1eaeeb901a7f359.zip
sci-libs/starparse: Add patch for guile-1.8
Package-Manager: portage-2.2.7
Diffstat (limited to 'sci-libs/starparse/starparse-9999.ebuild')
-rw-r--r--sci-libs/starparse/starparse-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-libs/starparse/starparse-9999.ebuild b/sci-libs/starparse/starparse-9999.ebuild
index 09265fc2b..1c54b5601 100644
--- a/sci-libs/starparse/starparse-9999.ebuild
+++ b/sci-libs/starparse/starparse-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-AUTOTOOLS_AUTORECONF="true"
+AUTOTOOLS_AUTORECONF=yes
inherit autotools-utils git-r3
@@ -15,11 +15,15 @@ EGIT_REPO_URI="git://burrow-owl.git.sourceforge.net/gitroot/burrow-owl/starparse
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="guile static-libs"
+IUSE="guile static-libs test"
+
+REQUIRED_USE="test? ( guile )"
RDEPEND="guile? ( dev-scheme/guile:12 )"
DEPEND="${RDEPEND}
- virtual/pkconfig"
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-guile1.8.patch )
src_configure() {
local myeconfargs=( $(use_enable guile) )