aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-11-04 20:24:50 -0600
committerChristoph Junghans <ottxor@gentoo.org>2011-11-04 20:24:50 -0600
commit16d9a40433142d529a9642364ce8a42c8822753e (patch)
tree4d5bb28d982e9f7d5d2bdb9197bbbd947e2b85a8 /sci-libs/votca-tools/votca-tools-9999.ebuild
parentlive ebuild update (diff)
downloadsci-16d9a40433142d529a9642364ce8a42c8822753e.tar.gz
sci-16d9a40433142d529a9642364ce8a42c8822753e.tar.bz2
sci-16d9a40433142d529a9642364ce8a42c8822753e.zip
EAPI bump + multilib support
(Portage version: 2.2.0_alpha72/git/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs/votca-tools/votca-tools-9999.ebuild')
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index 97ee2faac..ccda98173 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+EAPI=4
-inherit cmake-utils eutils
+inherit cmake-utils eutils multilib
if [ "${PV}" != "9999" ]; then
SRC_URI="system-boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
@@ -56,16 +56,16 @@ src_configure() {
$(cmake-utils_use_with fftw FFTW)
$(cmake-utils_use_with sqlite SQLITE3)
-DWITH_RC_FILES=OFF
+ -DLIB=$(get_libdir)
)
- cmake-utils_src_configure || die
+ cmake-utils_src_configure
}
src_install() {
- cmake-utils_src_install || die
+ cmake-utils_src_install
if use doc; then
- cd "${CMAKE_BUILD_DIR}" || die
- cd share/doc || die
- doxygen || die
- dohtml -r html/* || die
+ cd "${CMAKE_BUILD_DIR}"
+ emake html
+ dohtml -r share/doc/html/*
fi
}