aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-02-12 14:59:54 +0100
committerChristoph Junghans <ottxor@gentoo.org>2011-02-12 15:05:20 +0100
commit33ef80d5033a5e8c39978cd7911ad1efe8b4aede (patch)
tree61062af3fc16ed9ed67801103e05a09ba9b079e3 /sci-libs/votca-tools/votca-tools-9999.ebuild
parentMoved sci-math/jags to main tree per bug 317741 (diff)
downloadsci-33ef80d5033a5e8c39978cd7911ad1efe8b4aede.tar.gz
sci-33ef80d5033a5e8c39978cd7911ad1efe8b4aede.tar.bz2
sci-33ef80d5033a5e8c39978cd7911ad1efe8b4aede.zip
[sci-libs/votca-tools] version bump
(Portage version: 2.1.9.25/git/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs/votca-tools/votca-tools-9999.ebuild')
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index dc396eea0..ad2a6d647 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -8,6 +8,7 @@ inherit eutils autotools-utils
if [ "${PV}" != "9999" ]; then
SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz"
+ RESTRICT="primaryuri"
else
SRC_URI=""
inherit mercurial
@@ -29,7 +30,7 @@ RDEPEND="fftw? ( sci-libs/fftw:3.0 )
boost? ( dev-libs/boost )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
+ doc? ( app-doc/doxygen[-nodot] )
>=app-text/txt2tags-2.5
dev-util/pkgconfig"
@@ -43,10 +44,11 @@ src_prepare() {
rm -rf src/libboost
else
#fix a qa issue ../../config is not support as m4 dir
- mkdir -p src/libboost/config
+ mkdir -p src/libboost/config || die
sed -i 's@\.\./\.\./config@config@' \
src/libboost/configure.ac \
- src/libboost/Makefile.am
+ src/libboost/Makefile.am || \
+ die "sed of libboost configure.ac and Makefile.am failed"
fi
eautoreconf || die "eautoreconf failed"
}
@@ -59,12 +61,12 @@ src_configure() {
$(use_with gsl)
$(use_with fftw)
)
- autotools-utils_src_configure
+ autotools-utils_src_configure || die
}
src_install() {
DOCS=(${AUTOTOOLS_BUILD_DIR}/CHANGELOG NOTICE)
- autotools-utils_src_install
+ autotools-utils_src_install || die
if use doc; then
cd share/doc
doxygen || die