aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <kleiner_otti@gmx.de>2009-12-13 12:24:11 +0100
committerChristoph Junghans <kleiner_otti@gmx.de>2009-12-13 12:24:11 +0100
commit1ca268925ec408304aa7ed4bc7dee031713beeb1 (patch)
treecbdec0d15b4225233c4b0c32c55cd2033949b3d6 /sci-libs/votca-tools
parentDeleted because it's in the main tree (diff)
downloadsci-1ca268925ec408304aa7ed4bc7dee031713beeb1.tar.gz
sci-1ca268925ec408304aa7ed4bc7dee031713beeb1.tar.bz2
sci-1ca268925ec408304aa7ed4bc7dee031713beeb1.zip
sci-libs/votca-tools initial add - bug #296707
(Portage version: 2.1.6.13/git/Linux i686) (Signed Manifest commit)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog10
-rw-r--r--sci-libs/votca-tools/Manifest14
-rw-r--r--sci-libs/votca-tools/metadata.xml9
-rw-r--r--sci-libs/votca-tools/votca-tools-1.0_rc1.ebuild40
4 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
new file mode 100644
index 000000000..d53b19156
--- /dev/null
+++ b/sci-libs/votca-tools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/votca-tools
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*votca-tools-1.0_rc1 (13 Dec 2009)
+
+ 13 Dec 2009; Christoph Junghans <kleiner_otti@gmx.de>
+ +votca-tools-1.0_rc1.ebuild, +metadata.xml:
+ initial add bug #296707
+
diff --git a/sci-libs/votca-tools/Manifest b/sci-libs/votca-tools/Manifest
new file mode 100644
index 000000000..9d4421888
--- /dev/null
+++ b/sci-libs/votca-tools/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST votca-tools-1.0_rc1.tar.gz 109653 RMD160 f87710a415d07490432cc1be974f960fa47b15ec SHA1 f174319f8b2b4716412837d64d23d8a1d32bad2d SHA256 3f04198ab04f75ba4d8185ee7635c808556cfec9f22d2d09f691e26b15bb18b7
+EBUILD votca-tools-1.0_rc1.ebuild 688 RMD160 a62a5235538b3018f78925c0d06fc907499c41b5 SHA1 e09d9863dba753fc7d5d4717237583ad2dd53eb0 SHA256 bb77859192572f2d8f29f8eeca10c9d116f39ee569ebe75038388f04837a16e3
+MISC ChangeLog 286 RMD160 11df623816873b7acdcc0453445a4f1d0b29703c SHA1 3403b4a387d9bfe5bf77696ab3faae1484f670ac SHA256 0de220113eb7b0f7d57dba4ae8c338f4d492a3a103945ad0d674192a184376fc
+MISC metadata.xml 256 RMD160 53a5d04f6246118e052c9cae27b7070de9b88529 SHA1 563e3277f01cc3bf484d46a6da50719855a5a689 SHA256 e683c0d7d2051297085cdbb7444ce887044c7ed0ba02cf04be170cdf62919c74
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkskztsACgkQy0OE/ans1/lniACfcwrXybWj2g0/6MlKBCZ2jLGb
+8oYAnjm0Cmf4k5LRjMNhKIflCL3tKQmK
+=byug
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/votca-tools/metadata.xml b/sci-libs/votca-tools/metadata.xml
new file mode 100644
index 000000000..69b66cbec
--- /dev/null
+++ b/sci-libs/votca-tools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+ <maintainer>
+ <email>kleiner_otti@gmx.de</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/votca-tools/votca-tools-1.0_rc1.ebuild b/sci-libs/votca-tools/votca-tools-1.0_rc1.ebuild
new file mode 100644
index 000000000..d93451ae5
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.0_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+SRC_URI="http://www.votca.org/downloads/votca-tools-1.0_rc1.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sci-libs/fftw:3.0
+ dev-libs/libxml2
+ sci-libs/gsl
+ >=dev-libs/boost-1.33.1"
+
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ econf || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ #dodoc NOTICE
+}